Bug 218388 - Logrotate should rotate logs even if there are some errors on the configuration
Summary: Logrotate should rotate logs even if there are some errors on the configuration
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: logrotate   
(Show other bugs)
Version: 4.4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Tomas Smetana
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On: 166510
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-12-04 23:54 UTC by Xixi
Modified: 2018-10-19 20:22 UTC (History)
3 users (show)

Fixed In Version: RHBA-2008-0703
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-24 19:52:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2008:0703 normal SHIPPED_LIVE logrotate bug fix and enhancement update 2008-07-23 16:31:04 UTC

Comment 7 Jason Haar 2007-02-27 03:28:12 UTC
I think this is a "me too".


We had a rpm install of snort, where we later reconfigured it so that it didn't
write logfiles under /var/log/snort/*/* - as refered to in it's logrotate.d file.

However, when logrotate runs, it can't find any subdirs under /var/log/snort (as
we had deleted them), AND IT EXITED - CEASING TO RUN OTHER logrotate FILES!!

We found out a week later when the huge (un-rotated) squid logfiles crashed
squid :-/

i.e if you have a logrotate config file that refers to files in directories that
don't exist, logrotate exits, not running any remaining logrotate jobs. I don't
know if this is an exact match for this ticket - but I assume so?


I think there should be no such dependencies. The status of one logrotate config
file should not impact any others. Isn't that the point of RPMs - keep things
nice and separate?

Thanks!

Jason

Comment 10 Tomas Smetana 2007-08-03 09:58:58 UTC
It seems to be too late for 4.6, moving to 4.7.

Comment 11 RHEL Product and Program Management 2007-11-29 04:23:03 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 19 errata-xmlrpc 2008-07-24 19:52:05 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0703.html


Note You need to log in before you can comment on or make changes to this bug.