Bug 2183971 - golang-x-sys-0.8.0 is available
Summary: golang-x-sys-0.8.0 is available
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: golang-x-sys
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Robert-André Mauchin 🐧
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2023-04-03 09:54 UTC by Upstream Release Monitoring
Modified: 2023-05-17 01:30 UTC (History)
5 users (show)

Fixed In Version: golang-x-sys-0.8.0-1.fc37 golang-x-sys-0.8.0-1.fc38
Doc Type: ---
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-05-17 01:11:05 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
Update to 0.7.0 (#2183971) (664 bytes, patch)
2023-04-05 19:55 UTC, Upstream Release Monitoring
no flags Details | Diff
Update to 0.8.0 (#2183971) (664 bytes, patch)
2023-05-05 04:14 UTC, Upstream Release Monitoring
no flags Details | Diff

Description Upstream Release Monitoring 2023-04-03 09:54:46 UTC
Releases retrieved: 0.1.0, 0.2.0, 0.3.0, 0.4.0, 0.5.0, 0.6.0
Upstream release that is considered latest: 0.6.0
Current version/release in rawhide: 0.5.0-1.fc39
URL: https://golang.org/x/sys

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/335970/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/golang-x-sys

Comment 1 Upstream Release Monitoring 2023-04-03 09:54:52 UTC
Scratch build failed. Details below:

GenericError: File upload failed: cli-build/1680515690.7528532.pHMaxqSn/golang-x-sys-0.6.0-1.fc36.src.rpm
Traceback:
  File "/usr/local/lib/python3.10/site-packages/hotness/use_cases/package_scratch_build_use_case.py", line 56, in build
    result = self.builder.build(request.package, request.opts)
  File "/usr/local/lib/python3.10/site-packages/hotness/builders/koji.py", line 198, in build
    output["build_id"] = self._scratch_build(session, package.name, srpm)
  File "/usr/local/lib/python3.10/site-packages/hotness/builders/koji.py", line 451, in _scratch_build
    session.uploadWrapper(source, serverdir)
  File "/usr/lib/python3.10/site-packages/koji/__init__.py", line 3110, in uploadWrapper
    self.fastUpload(localfile, path, name, callback, blocksize, overwrite, volume=volume)
  File "/usr/lib/python3.10/site-packages/koji/__init__.py", line 3034, in fastUpload
    raise GenericError("File upload failed: %s/%s" % (path, name))

If you think this issue is caused by some bug in the-new-hotness, please report it on the-new-hotness issue tracker: https://github.com/fedora-infra/the-new-hotness/issues

Comment 2 Upstream Release Monitoring 2023-04-05 19:55:08 UTC
Releases retrieved: 0.7.0
Upstream release that is considered latest: 0.7.0
Current version/release in rawhide: 0.5.0-1.fc39
URL: https://golang.org/x/sys

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/335970/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/golang-x-sys

Comment 3 Upstream Release Monitoring 2023-04-05 19:55:13 UTC
Created attachment 1955972 [details]
Update to 0.7.0 (#2183971)

Comment 4 Upstream Release Monitoring 2023-04-05 20:01:51 UTC
the-new-hotness/release-monitoring.org's scratch build of golang-x-sys-0.7.0-1.fc36.src.rpm for rawhide completed http://koji.fedoraproject.org/koji/taskinfo?taskID=99567488

Comment 5 Upstream Release Monitoring 2023-05-05 04:14:04 UTC
Releases retrieved: 0.8.0
Upstream release that is considered latest: 0.8.0
Current version/release in rawhide: 0.5.0-1.fc39
URL: https://golang.org/x/sys

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/335970/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/golang-x-sys

Comment 6 Upstream Release Monitoring 2023-05-05 04:14:09 UTC
Created attachment 1962468 [details]
Update to 0.8.0 (#2183971)

Comment 7 Upstream Release Monitoring 2023-05-05 04:22:15 UTC
the-new-hotness/release-monitoring.org's scratch build of golang-x-sys-0.8.0-1.fc36.src.rpm for rawhide completed http://koji.fedoraproject.org/koji/taskinfo?taskID=100754033

Comment 8 Fedora Update System 2023-05-08 01:22:33 UTC
FEDORA-2023-61791ec19c has been submitted as an update to Fedora 37. https://bodhi.fedoraproject.org/updates/FEDORA-2023-61791ec19c

Comment 9 Fedora Update System 2023-05-08 01:22:59 UTC
FEDORA-2023-5f9e751993 has been submitted as an update to Fedora 38. https://bodhi.fedoraproject.org/updates/FEDORA-2023-5f9e751993

Comment 10 Fedora Update System 2023-05-09 02:38:40 UTC
FEDORA-2023-61791ec19c has been pushed to the Fedora 37 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-61791ec19c`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-61791ec19c

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 11 Fedora Update System 2023-05-09 03:16:31 UTC
FEDORA-2023-5f9e751993 has been pushed to the Fedora 38 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-5f9e751993`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-5f9e751993

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 12 Fedora Update System 2023-05-17 01:11:05 UTC
FEDORA-2023-61791ec19c has been pushed to the Fedora 37 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 13 Fedora Update System 2023-05-17 01:30:17 UTC
FEDORA-2023-5f9e751993 has been pushed to the Fedora 38 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.