This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 218418 - kernel BUG at drivers/xen/core/evtchn.c:481!
kernel BUG at drivers/xen/core/evtchn.c:481!
Status: CLOSED DUPLICATE of bug 211986
Product: Fedora
Classification: Fedora
Component: kernel-xen (Show other bugs)
6
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Xen Maintainance List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-05 03:10 EST by Jeff Cox
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-05 10:00:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Cox 2006-12-05 03:10:42 EST
Description of problem:
Dom0 lockup when loading ipvsadm in a domU.

Version-Release number of selected component (if applicable):
Kernel 2.6.18-1.2849.fc6xen on an i686

How reproducible:
Load ipvsadm in a domU.
  
Actual results:
The capture below was from inside a domU when dom0 died:

Loading additional iptables modules: ip_conntrack_netbios_ns [  OK  ]
Clearing the current IPVS table: [  OK  ]
Applying IPVS configuration: /etc/rc3.d/S08ipvsadm: line 62: /etc/sysconfig/ipvsadm: No such file or 
directory
[FAILED]
Bringing up loopback interface:  [  OK  ]
Bringing up interface eth0:  

Message from syslogd@jupiter at Mon Dec  4 23:07:40 2006 ...
jupiter kernel: ------------[ cut here ]------------
jupiter kernel: kernel BUG at drivers/xen/core/evtchn.c:481!
jupiter kernel: invalid opcode: 0000 [#1]
jupiter kernel: SMP 
jupiter kernel: CPU:    1
jupiter kernel: EIP is at retrigger+0x22/0x38
jupiter kernel: eax: 00000000   ebx: 02080000   ecx: f5416000   edx: 0000002c
jupiter kernel: esi: c06d4200   edi: 0000011c   ebp: 00000000   esp: c0d6ce5c
jupiter kernel: ds: 007b   es: 007b   ss: 0069
jupiter kernel: Process xenwatch (pid: 37, ti=c0d6c000 task=c0d027a0 task.ti=c0d6c000)
jupiter kernel: Stack: c0442841 c06d4200 0000011c c06d4228 c0442585 00000000 00000000 
c1123a60 
jupiter kernel:        000000f8 dee28c00 dee28c00 00000000 00000419 dee28c00 ee856942 
00000000 
jupiter kernel:        ee856d5d dee28800 dee28c00 c063e139 c054b0b9 00000000 c063e1dd 
00000419 
jupiter kernel: Call Trace:
jupiter kernel:  [<c0442841>] check_irq_resend+0x41/0x48
jupiter kernel:  [<c0442585>] enable_irq+0x92/0xad
jupiter kernel:  [<ee856942>] __netif_up+0xb/0x13 [netbk]
jupiter kernel:  [<ee856d5d>] netif_map+0x241/0x269 [netbk]
jupiter kernel:  [<ee8561d3>] maybe_connect+0x2cc/0x49b [netbk]
jupiter kernel:  [<c054c9de>] otherend_changed+0x74/0x79
jupiter kernel:  [<c054af2f>] xenwatch_handle_callback+0x12/0x44
jupiter kernel:  [<c054b9f8>] xenwatch_thread+0x108/0x11e
jupiter kernel:  [<c042e013>] kthread+0xc0/0xed
jupiter kernel:  [<c0402a69>] kernel_thread_helper+0x5/0xb
jupiter kernel: DWARF2 unwinder stuck at kernel_thread_helper+0x5/0xb
jupiter kernel: Leftover inexact backtrace:
jupiter kernel:  =======================
jupiter kernel: Code: 75 96 5e 5f 5b 5e 5f 5d c3 8b 04 85 a0 1d 7f c0 8b 0d c4 a7 66 c0 66 85 c0 74 
20 0f b7 d0 0f a3 91 80 08 00 00 19 c0 85 c0 75 08 <0f> 0b e1 01 33 d8 63 c0 f0 0f ab 91 00 08 00 
00 b8 01 00 00 00 
jupiter kernel: EIP: [<c05468a2>] retrigger+0x22/0x38 SS:ESP 0069:c0d6ce5c
[  OK  ]
Bringing up interface eth1:

--- machine dead ---
Comment 1 Jeff Cox 2006-12-05 03:12:51 EST
Machine is an IBM xSeries 360 with 4 Xeon MP's and 8 Gig's of RAM.
Comment 2 Stephen Tweedie 2006-12-05 10:00:29 EST

*** This bug has been marked as a duplicate of 211986 ***

Note You need to log in before you can comment on or make changes to this bug.