Bug 218419 - xine-lib will not play back MPEG files
xine-lib will not play back MPEG files
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xine-lib (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Aurelien Bompard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-05 03:19 EST by Daigoro Toyama
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-06 08:33:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daigoro Toyama 2006-12-05 03:19:39 EST
Description of problem:

This version of xine-lib will not play MPEG movie files.

Version-Release number of selected component (if applicable):

1.1.2-17

How reproducible:

Always

Steps to Reproduce:
1. Use an MPEG (*.mpg) movie file.
2. Attempt to view it using Kaffeine, which uses xine-lib.
  
Actual results:

The error message saying "No plugins found" pops up.

Expected results:

The movie playback should start.

Additional info:

The Livna package, xine-lib-1.1.2-4.lvn5.i386.rpm, works perfectly. Once I run
"yum update" to update it to the Extras 1.1.2-17 version, then the MPEG playback
will not work anymore.
Comment 1 Ville Skyttä 2006-12-06 08:33:25 EST
Software MPEG playback cannot be included in Fedora packages due to patent issues.
http://fedoraproject.org/wiki/ForbiddenItems
Comment 2 Daigoro Toyama 2006-12-09 20:06:38 EST
Fine, but then why did you make it so it would "update" an existing Livna
version, which plays back MPEG? At least should you not make sure the Extras
version should not overwrite the Livna version?
Comment 3 Michael Schwendt 2006-12-10 03:37:30 EST
No: yum install xine-lib-extras-nonfree
Comment 4 Daigoro Toyama 2006-12-10 05:27:30 EST
The problem is, for the customer who already has the Livna version of xine-lib
installed on their system, there's no way of knowing the change. All we see is
the  updated version of xine-lib suddenly not working anymore. How are we
supposed to know that xine-lib-extras-nonfre is now available via Livna? Just
running "yum" won't tell us anything like that.

I don't want to sound bitter, but this is one extra step that I had to take to
do what I've been doing without any problem. I'd certainly understand it if the
change came along with a new version, such as FC6.

Comment 5 Michael Schwendt 2006-12-10 06:18:44 EST
The term "customer" is inappropriate. ;)

As "a user" of a 3rd party repository, you may need to stay informed about
any incompatible changes in package development which affect you. There
are mailing-lists, for instance, where moving xine-lib has been a topic.

Fedora Extras is free to override packages from 3rd party repositories
any time. Even in cases where some coordination is possible, often it is
much more convenient to just go ahead with a change instead of trying to
spend a lot of time into trying to come up with a smart solution that might
suffer from other pitfalls.

Whether this change could have been announced in a (hopefully) prominant
place, is a different topic. Much of Fedora Extras and Livna would benefit
from additional contributors.

Note You need to log in before you can comment on or make changes to this bug.