Bug 218428 - Can't install OS on ATI SB600 chipset with legacy IDE mode
Can't install OS on ATI SB600 chipset with legacy IDE mode
Status: CLOSED DUPLICATE of bug 203781
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Red Hat Kernel Manager
Brian Brock
Depends On:
Blocks: 227594 227595 227596
  Show dependency treegraph
Reported: 2006-12-05 05:26 EST by Xin-Yun Liu (Wolke Liu)
Modified: 2007-11-30 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-07-11 13:54:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
patch for ATI SB600 legacy IDE mode (1.68 KB, text/plain)
2006-12-21 01:17 EST, Xin-Yun Liu (Wolke Liu)
no flags Details

  None (edit)
Description Xin-Yun Liu (Wolke Liu) 2006-12-05 05:26:35 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322; .NET CLR 2.0.50727)

Description of problem:
Set SATA mode as legacy IDE, install os failed on ATI SB600 chipset

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Set SATA mode as legacy IDE in system BIOS 
2. Install OS from SATA hard disk

Actual Results:
install failed for don't have such sata driver.

Expected Results:
driver should treat the SATA in ahci mode instead of legacy ide mode

Additional info:
Comment 1 Xin-Yun Liu (Wolke Liu) 2006-12-21 01:17:27 EST
Created attachment 144162 [details]
patch for ATI SB600 legacy IDE mode

set the controller back to AHCI mode if it has been set as IDE by BIOS
Comment 2 Xin-Yun Liu (Wolke Liu) 2006-12-21 01:25:24 EST
I have tested it successfully on the ATI Marlin (SB600),

The system bios information:
Version: 08.00.04
Build Date: 11/10/06
ID: AMM66B27
Comment 3 Xin-Yun Liu (Wolke Liu) 2006-12-25 03:22:30 EST
Could anyone add the pacth to RHEL5 before the final release?

BTW, correct the mainboard information:
ATI (Marlin RS600) bios version: AMML6B54
ATI (Moray RS690), bios verison: AMM66B27

Comment 4 RHEL Product and Program Management 2007-04-25 18:55:32 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
Comment 5 Prarit Bhargava 2007-07-11 13:54:17 EDT

*** This bug has been marked as a duplicate of 203781 ***

Note You need to log in before you can comment on or make changes to this bug.