Bug 218489 - Old static entries in ifcfg-eth0 prevent dhclient from setting default route.
Old static entries in ifcfg-eth0 prevent dhclient from setting default route.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.0
All Linux
medium Severity medium
: rc
: ---
Assigned To: David Cantrell
David Lawrence
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-05 13:43 EST by Jay Fenlason
Modified: 2014-08-31 19:28 EDT (History)
3 users (show)

See Also:
Fixed In Version: RHBA-2008-0397
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 11:29:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
old ifcfg-eth0 (102 bytes, text/plain)
2006-12-06 12:35 EST, Jay Fenlason
no flags Details
anaconda-218489.patch (654 bytes, patch)
2008-01-07 13:50 EST, David Cantrell
no flags Details | Diff

  None (edit)
Description Jay Fenlason 2006-12-05 13:43:38 EST
Description of problem: 
Old static config in /etc/sysconfig/network-scripts/ifcfg-eth0 prevents 
dhclient from setting default route 
 
Version-Release number of selected component (if applicable): 
initscripts-8.45.4.EL-1 
 
How reproducible: 
 
 
Steps to Reproduce: 
1.Configure a rhel4 box with a static IP configuration, then change the 
configuration to use DHCP. 
2.Upgrade the box to rhel5 
3.Observe that the box can no longer access machines beyond the local network. 
   
Actual results: 
 
 
Expected results: 
Network configuration should continue to work as it did in RHEL-4. 
 
Additional info:
Comment 1 Bill Nottingham 2006-12-05 13:53:23 EST
What are the config files?
Comment 2 Jay Fenlason 2006-12-06 12:35:02 EST
Created attachment 142969 [details]
old ifcfg-eth0

Removing the last three lines "fixed" the problem, but it's still a regression
from RHEL4.
Comment 3 Bill Nottingham 2006-12-06 15:29:17 EST
This is done in dhclient-script (*yuk*).
Comment 4 RHEL Product and Program Management 2007-07-23 11:38:36 EDT
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 5 James Laska 2007-11-02 12:55:51 EDT
What's the proposed solution here?  Is dhclient-script being changed to honor
BOOTPROTO over IPADDR?
Comment 6 David Cantrell 2008-01-07 13:48:56 EST
This this isn't happening in dhclient-script, it happens in anaconda.  On
upgrade, we're preserving everything in the existing ifcfg-ethX file, which
shouldn't be happening.  Attached is a patch to fix the problem.
Comment 7 David Cantrell 2008-01-07 13:50:03 EST
Created attachment 290995 [details]
anaconda-218489.patch
Comment 10 Milan Zazrivec 2008-02-06 06:58:17 EST
Upgrade from RHEL4.6 AS to RHEL5.2-Server-20080206.nightly according to 
scenario in comment 0 works as expected.
Comment 12 errata-xmlrpc 2008-05-21 11:29:48 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0397.html

Note You need to log in before you can comment on or make changes to this bug.