Bug 218495 - Eclipse freezes when selecting/editing new jre from java preferences
Eclipse freezes when selecting/editing new jre from java preferences
Status: CLOSED DUPLICATE of bug 217843
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
6
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ben Konrath
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-05 13:56 EST by Mario Torre
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-06 15:15:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mario Torre 2006-12-05 13:56:05 EST
Description of problem:

I've found a problem in Eclipse 3.2.x.

Actually I have no output useful for debug, so I can only describe the problem.

Everytime I add/edit the JRE properties from Preferences->Java->Installed JRE
eclipse freeze and never return control to the user.

In more details, when I hit the [EDIT] button of an already installed JRE, or
the [ADD] button of a new JRE, the edit JRE dialog opens as usual, but when I
press the [BROWSE...] button it freezes. This happens with Eclipse 3.2.1
(upstream), with Fedora Eclipse (default), with any JDK configure as system JDK
(I've tried with gcj, Sun Java 1.5.0_10 and 1.6.0_rc1).

I'm not totally sure when this problem begun, as I use this feature once in a
while developing Classpath, so when I configure a new JDK there is no need for
me to come back on this dialogue, but I'm pretty sure to have used this feature
at least one time before the last gtk update.

My guess is that there is some threading issue with gtk that ends up in a
deadlock or something.

Anyway, as I don't have any output from Eclipse (tried with usual switch:
-consoleLog -verbose -debug etc...), I thought to report it as an Eclipse bug.

Version-Release number of selected component (if applicable):

Eclipse 3.2.x

How reproducible:

Steps to Reproduce:
1. Go to Preferences->Java->Installed JRE
2. Add a new JRE or edit one
3. Press the BROWSE button
  
Actual results:

Eclipse freezes

Expected results:

It should let the user to configure the Java Runtimes.

Additional info:
Comment 1 Andrew Overholt 2006-12-05 14:25:19 EST
I think this is a duplicate of bug #217843.  Specifically, I think this is a
manifestation of the SELinux part of that bug.  Dan Walsh has stated that a fix
for that is in selinux-policy-2.4.6-6 which I assume will be an FC6 update soon.
Comment 2 Mario Torre 2006-12-05 15:09:13 EST
I think I can confirm this (my /var/log/message when eclipse hungs):

Dec  5 20:59:19 nirvana dbus: Can't send to audit system: USER_AVC avc:  denied
 { send_msg } for msgtype=method_call interface=org.freedesktop.DBus
member=Hello dest=org.freedesktop.DBus spid=13362
scontext=user_u:system_r:java_t tcontext=user_u:system_r:unconfined_t
tclass=dbus : exe="/bin/dbus-daemon" (sauid=500, hostname=?, addr=?, terminal=?)

I think you can mark this bug as duplicated, if I have more info I'll let you know.

Thanks for the quick reply.
Comment 3 Ben Konrath 2007-02-06 15:15:19 EST

*** This bug has been marked as a duplicate of 217843 ***

Note You need to log in before you can comment on or make changes to this bug.