Bug 218514 - rawhide kernel-xen-debuginfo appears to have incorrect dependencies
rawhide kernel-xen-debuginfo appears to have incorrect dependencies
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel-xen (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Stephen Tweedie
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-05 15:19 EST by William Cohen
Modified: 2009-12-14 15:39 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-12 11:07:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description William Cohen 2006-12-05 15:19:45 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.13) Gecko/20060418 Fedora/1.0.8-1.1.fc4 Firefox/1.0.8

Description of problem:
The debuginfo dependencies for the xen-debuginfo appear to be wrong. When attempting to yum update rawhide see the following on x86_64:

Error: Missing Dependency: kernel-debuginfo-common-x86_64 = 2.6.18-1.2849.fc6 is needed by package kernel-xen-debuginfo

However, that name doesn't seem to match up with the kernel-debuginfo-common created for x86-64, kernel-debuginfo-common-2.6.18-1.2849.fc6.x86_64.rpm.


See the same on i686.

-Will

Version-Release number of selected component (if applicable):
kernel 2.6.18-1.2849.fc6

How reproducible:
Always


Steps to Reproduce:
1.  sudo yum --enablerepo=development  --enablerepo=development-debuginfo --disablerepo=extras-development upgrade
2.
3.

Actual Results:
See the error message about missing dependency.

Expected Results:
Expect that dependency is resolved and all the needed debuginfo packages are installed.



Additional info:
Comment 2 Red Hat Bugzilla 2007-07-24 21:36:41 EDT
change QA contact
Comment 3 Eduardo Habkost 2007-11-12 11:07:11 EST
-debuginfo was disabled since Fedora 7, and re-enabled on Rawhide, just after 
Fedora 8 (bug #336351). The spec is completely different and this bug 
shouldn't be there anymore.

Note You need to log in before you can comment on or make changes to this bug.