Bug 218531 - serial port input on rhel5b2 is unreliable
Summary: serial port input on rhel5b2 is unreliable
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 5.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Aristeu Rozanski
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords: Regression
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-12-05 21:03 UTC by Jay Fenlason
Modified: 2014-08-31 23:28 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-19 20:35:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jay Fenlason 2006-12-05 21:03:29 UTC
Description of problem: 
ttyS1 on fenlason-lab2.lab.boston.redhat.com does not work well with the 
RHEL5B2 kernel. Many characters are getting dropped, and dmesg is filling with 
many lines saying 
ttyS1: 28 input overrun(s) 
(and other random numbers).  This makes the serial console to my rawhide box 
very hard to use. 
 
This hardware worked fine with RHEL4U4. 
 
Version-Release number of selected component (if applicable): 
kernel-2.6.18-1.2747.el5.i686 
 
How reproducible: 
Always 
 
Steps to Reproduce: 
1.minicom from the RHEL5B2 box to the rawhide box 
2.log in and cat /etc/motd on the rawhide box 
3.observe that the output is trashed 
   
Actual results: 
usually.  Sometimes you can cat /etc/motd successfully. 
 
Expected results: 
no garbled output 
 
Additional info:

Comment 1 Aristeu Rozanski 2007-02-08 22:17:57 UTC
Using acpi=off it's not possible to reproduce the problem.
Compaq Proliant ML350, BIOS version D04/F04 09/22/2000


Comment 2 Aristeu Rozanski 2007-02-08 22:44:38 UTC
Actually D04 is the model. Updated to a newer BIOS version. Seems the problem is
gone. Testing.


Comment 3 Aristeu Rozanski 2007-02-19 20:35:53 UTC
The BIOS upgrade fixed the problem.



Note You need to log in before you can comment on or make changes to this bug.