This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 218649 - RHEL 4 -> RHEL 5 Beta 2 upgrade process seems incompatiable with Installation Number usage
RHEL 4 -> RHEL 5 Beta 2 upgrade process seems incompatiable with Installation...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-06 11:44 EST by Clifford Perry
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-06 11:51:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
upgrade.log (27.02 KB, text/plain)
2006-12-06 11:44 EST, Clifford Perry
no flags Details
upgrade.log.syslog (1.17 KB, application/octet-stream)
2006-12-06 11:45 EST, Clifford Perry
no flags Details

  None (edit)
Description Clifford Perry 2006-12-06 11:44:41 EST
Description of problem:
Within announcement -
https://www.redhat.com/archives/rhelv5-announce/2006-November/msg00003.html - we
are given various installation numbers to use. 

For myself, I attempted to upgrade my RHEL 4.4 Desktop system to RHEL 5 Beta 2
Client - using IN:

+ Red Hat Enterprise Linux Desktop + Workstation + DualOS Option
   (Virtualization):
   7fcc43557e9bbc42

I would expect that because I choose this, the installation would know that even
though I am performing an OS upgrade, that I also want the anaconda installer to
add to the OS all the 'extra' bits that come as part of this install. 

This did not happen though, and instead, post installation I had to manually add
all the *xen* packages that are available on the install ISO/DVD and/or RHN RHEL
5 beta child channels. 

To me there seems to be a general disconnect, where an upgrade, *only* attempts
to upgrade already pre-installed packages, and takes no consideration of new
additional packages that should be added to the OS as part of the upgrade process. 

I will attach the resultant /root/upgrade.log* files. 


Version-Release number of selected component (if applicable):
This was using the RHEl 5 beta 2 ISO's 

How reproducible:
I assume always, only tested once, on my main laptop I use for work. 

Steps to Reproduce:
1. Install RHEL 4.4 Desktop 
2. Insert disk 1 ISO and perform upgrade of OS
3. When prompted enter in "7fcc43557e9bbc42"
4. Note at end that Xen (DualOS Option
   (Virtualization)) did not get added. 
  
Actual results:


Expected results:


Additional info:
Comment 1 Clifford Perry 2006-12-06 11:44:41 EST
Created attachment 142964 [details]
upgrade.log
Comment 2 Clifford Perry 2006-12-06 11:45:39 EST
Created attachment 142965 [details]
upgrade.log.syslog
Comment 3 Jeremy Katz 2006-12-06 11:51:31 EST
Upgrades by design do *NOT* add new packages except as required by dependencies.
 It's way too difficult to figure out what the actual intent is given the amount
of  flexibility around removing packages, etc

Note You need to log in before you can comment on or make changes to this bug.