Bug 218653 - How to allow execheap for MATLAB?
How to allow execheap for MATLAB?
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-06 11:46 EST by Orion Poplawski
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-14 10:12:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2006-12-06 11:46:44 EST
Description of problem:

Seeing:

Dec  5 17:01:02 cappello kernel: audit(1165363262.476:151): avc:  denied  {
execheap } for  pid=4276 comm="MATLAB" scontext=user_u:system_r:unconfined_t:s0
tcontext=user_u:system_r:unconfined_t:s0 tclass=process

Is there any way other than allow_execheap=1 to give MATLAB execheap permission?

Version-Release number of selected component (if applicable):
selinux-policy-2.4.5-4.fc5
Comment 1 Daniel Walsh 2007-02-14 10:07:07 EST
No.  You could write policy for it.  Sorry about loosing this bug in the stream
of bugzillas.
Comment 2 Daniel Walsh 2007-02-14 10:08:27 EST
This should really be reported as a bug in MATLAB.
Comment 3 Daniel Walsh 2007-02-14 10:12:27 EST
One evil hack that you could do would be to assign java_exec_t to the executable.
Jave currently has the execheap permission.
Comment 4 Orion Poplawski 2007-02-14 11:53:09 EST
Not a bad idea actually, since I think it is the Java parts of matlab that's
causing the problem.
Comment 5 Daniel Walsh 2007-02-14 15:17:09 EST
What is the path to matlab?
Comment 6 Orion Poplawski 2007-02-16 13:55:10 EST
Well, that's tricky because you can install it anywhere.  In our case, we
install it on our NFS server which causes problems with SELinux.  Or in
/opt/local/matlab on our laptops, or at least symbolic links are there that
point to the real install in /export/local/matlab_r2006a (or whatever version).
 The binary is then in some location like /opt/local/matlab/bin/<arch>/MATLAB.

Also, looks likes this is in the policy:

/usr/local/matlab.*/bin/glnx86/libmwlapack\.so --
system_u:object_r:textrel_shlib_t:s0

I've added the following as well:

/export/local/matlab.*/sys/os/glnx86/libtermcap.so   
system_u:object_r:textrel_shlib_t:s0
/export/local/matlab.*/bin/glnx86/(libmw(lapack|mathutil|services)|lapack|libmkl).so
   system_u:object_r:textrel_shlib_t:s0

Note You need to log in before you can comment on or make changes to this bug.