Bug 21867 - Scrollbar drawing bug in 'Basic' theme
Summary: Scrollbar drawing bug in 'Basic' theme
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gtk-engines (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Owen Taylor
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-12-07 01:58 UTC by Ed McKenzie
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-02 01:07:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ed McKenzie 2000-12-07 01:58:28 UTC
The 'Basic' theme's scrollbars destroy their outline when the scrollers
(both horizontal and vertical) are dragged. The scrollers also appear to
shift slightly in their track when moved.

Comment 1 Ed McKenzie 2000-12-07 02:01:50 UTC
The problem seems to be alleviated by closing and reopening gtk apps. It seems
to me that changing themes shouldn't require a restart...

Comment 2 Elliot Lee 2001-02-02 01:07:52 UTC
Confirmed

Comment 3 Owen Taylor 2001-07-19 22:08:35 UTC
There are a lot of busted themes out there. The only resolution I could
really do for this is to remove the theme. GTK+-2.0 allows for more
flexibility for themes, so the type of bad-hacks that cause problems
like this should no longer be necesary once we switch to that.


Note You need to log in before you can comment on or make changes to this bug.