Bug 218674 - Snort Package Fails Installation
Snort Package Fails Installation
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: snort (Show other bugs)
5
All Linux
medium Severity high
: ---
: ---
Assigned To: Dennis Gilmore
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FE7Target
  Show dependency treegraph
 
Reported: 2006-12-06 13:34 EST by Chris Taylor
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.6.1.1-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-01 17:35:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Taylor 2006-12-06 13:34:07 EST
Description of problem:
Package incorrectly installs /usr/lib/snort/dynamicengine/libsf_engine.so as the
file /usr/lib/snort/dynamicengine

Version-Release number of selected component (if applicable):
snort-2.6.0.2-2.fc5.i386.rpm

How reproducible:
See steps below

Steps to Reproduce:
1. Load FC5 for i386
2. D/L and install snort rpm.
3. file /usr/lib/snort/dynamicengine
  
Actual results:
It's a lib file

Expected results:
Should be the directory with the file libsf_engine.so inside it.

Additional info:
Numerous people have been unable to get this package to work correctly (please
see the snort newbies forums).  Please verify that it works correctly via
setting it up on a local lan with 2 other computers and verify that you can get
snort to detect a nmap portscan from one computer against another.
Comment 1 Michael Schwendt 2006-12-19 15:37:18 EST
Looks like "EasyFix". The spec contains this,

install libsf_engine.so %{buildroot}%{_libdir}/snort/dynamicengine
install libsf_engine.so.0 %{buildroot}%{_libdir}/snort/dynamicengine
install libsf_engine.so.0.0.0 %{buildroot}%{_libdir}/snort/dynamicengine

which would fail in the described way when the target is not a directory.
Comment 2 Chris Taylor 2006-12-21 14:38:49 EST
I built snort from source on a FC5 machine and I was able to get snort to log
portscans from nmap.  Unfortunately, when I had previously loaded the FC snort
package on my FC5 box it was unable to detect the portscans (same config files).
 I  made an attempt to correct the issue above by manually renaming the file but
it appeared there might be some other non-trivial problem that is preventing the
packaged version snort from logging (my build from source works just fine with
the same config file).

Any thoughts on this issue?
Comment 3 Dennis Gilmore 2007-01-01 17:35:53 EST
Dynamic engine is now fixed.  and the build was able to detect a port scan.

Note You need to log in before you can comment on or make changes to this bug.