Bug 218691 - anaconda partitioning crash
anaconda partitioning crash
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: parted (Show other bugs)
6
x86_64 Linux
medium Severity urgent
: ---
: ---
Assigned To: David Cantrell
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-06 15:35 EST by Stuart MacDonald
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-30 14:00:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Stuart MacDonald 2006-12-06 15:35:12 EST
Description of problem:

During an install, during the partitioning process, I triggered:

Assertion (part->part_list == NULL) at disk.c:1807
In function ped_disk_remove_partition() failed.

In a previous install I had selected "default layout". This time I selected
"custom layout". I deleted all the partitions by selecting the top-most drive
(the LVM in one case, the actual drives in others) and "delete". Then I created
one new partition on my RAID-0 drive that spanned the entire drive. Then I
created a /boot that was 100 MB in size on the primary hd. Then I wanted to
look at the default layout again because I couldn't remember if it had
allocated a swap partition or not. So I hit Back. Then I picked "Remove all
partitions on selected drives and create default layout". Then it crashed.

Version-Release number of selected component (if applicable):

Fedora Core 6.

How reproducible:

I don't have time to try to reproduce it, sorry.

Steps to Reproduce:
1. See above.
2.
3.
  
Actual results:

Installer crash.

Expected results:

A default layout should have been created. (I had the Review... layout option
checked as well.)

Additional info:
Comment 1 David Cantrell 2007-01-30 14:00:36 EST
Just tested this scenario with a rawhide tree from 29-Jan-2007 and it doesn't
crash.  Closing this bug.

Note You need to log in before you can comment on or make changes to this bug.