Bug 218693 - Please move perl-RPM-Specfile to Extras
Please move perl-RPM-Specfile to Extras
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Bill Nottingham
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-06 15:46 EST by Robin Norwood
Modified: 2014-03-16 23:04 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-03 16:29:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robin Norwood 2006-12-06 15:46:12 EST
The latest version of perl-RPM-Specfile (1.51) now requires perl-YAML.

perl-YAML is in extras, however.  To solve this problem, we could:

o Move perl-YAML to core (which might not be such a bad idea, as YAML is getting
more popular)
or:
o Move perl-RPM-Specfile to Extras.

After some discussion on fedora-perl-devel list, consensus seems to be to move
perl-RPM-Specfile to Extras.
(see:https://www.redhat.com/archives/fedora-perl-devel-list/2006-December/msg00011.html)

Of course, there's some debate as to whether there will even *be* an extras for
FC7, or whatever it will be called. :-)

So, please Do The Right Thing with this package, whatever that is, bearing in
mind that there is a new dependency on perl-YAML, and the package doesn't really
need to be in the core distribution (though it should still be available).
Comment 1 Bill Nottingham 2006-12-06 15:47:13 EST
Have you put it through the package review process for Extras, had it approved, etc?
Comment 2 Robin Norwood 2006-12-06 15:52:17 EST
Ah, no - is there a separate process for Core -> Extras, or the same process?
Comment 3 Bill Nottingham 2006-12-06 15:54:30 EST
At the moment, the process from Core->Extras is the same as the process from
<nowhere>->Extras.

I don't want to know why perl-RPM-Specfile now requires YAML, do I?
Comment 4 Bug Zapper 2008-04-03 14:45:38 EDT
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 5 Jesse Keating 2008-04-03 16:29:55 EDT
There is no Extras...

Note You need to log in before you can comment on or make changes to this bug.