Bug 218717 - gnome-common needs Requires automake < 1.10
gnome-common needs Requires automake < 1.10
Product: Fedora
Classification: Fedora
Component: gnome-common (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Toshio Kuratomi
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2006-12-06 17:35 EST by sean
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-12-07 01:50:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description sean 2006-12-06 17:35:22 EST
Description of problem:

/usr/bin/gnome-autogen.sh dies with automake > 1.9

I filed this bug here because gnome-common is not listed in bugzilla.

gnome-autogen.sh will not accept automake > 1.9:

    1.4*) automake_progs="automake-1.4" ;;
    1.5*) automake_progs="automake-1.5 automake-1.6 automake-1.7 automake-1.8
automake-1.9" ;;
    1.6*) automake_progs="automake-1.6 automake-1.7 automake-1.8 automake-1.9" ;;
    1.7*) automake_progs="automake-1.7 automake-1.8 automake-1.9" ;;
    1.8*) automake_progs="automake-1.8 automake-1.9" ;;
    1.9*) automake_progs="automake-1.9" ;;

At the least, the rpm for gnome-common should have a Require for the correct
version of automake.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
Actual results:

Expected results:

Additional info:

Maybe you could even nudge upstream to include automake-1.10 :)
Comment 1 Toshio Kuratomi 2006-12-06 17:49:27 EST
I'll go nudge upstream.
Comment 2 Toshio Kuratomi 2006-12-06 19:31:02 EST
The fixes are in upstream CVS.  I'm thinking of updating to a CVS snapshot.  The
only major change I see is:

2005-09-20  Stepan Kasal  <kasal@ucw.cz>

	* macros2/gnome-autogen.sh: Prefer newer versions of Automake.
	From bug #305641.

Which means if you have automake 1.5, 1.8, and 1.10 installed and didn't
configure  a specific version, the old gnome-common would use 1.5.  The new
gnome-common will use 1.10.

It looks like James Henstridge did some extensive testing with the change and
found only one breakage in gnome's cvs tree (has been fixed.)  The changes have
been in gnome-common being used by the modules in gnome-cvs for over a year. 
I'll put this in devel tonight.
Comment 4 sean 2006-12-07 10:34:34 EST
Works For Me

But don't we still need a Requires in the spec file?

Comment 5 Toshio Kuratomi 2006-12-07 14:29:05 EST
Didn't mean to close this earlier, sorry.  Closed now fixed for next release --

Re: Comment #4

It's a bit complex.  gnome-common will work with any version of automake from
1.4 up.  So I don't need the automake package, I need something that provides an
automake[VERSION] program and the scripts to back it up.

In Fedora we have automake "compat" packages automake14, automake18, etc which
satisfy this need.  Just using Require: automake <= 1.10 won't pick up these
additional packages.

automake and the automake compat packages don't have any sort of virtual provide
that I can depend on (Like Provides: automake(abi) = 1.4) so I'm unable to
Require: automake(abi) >= 1.4, automake(abi) <= 1.10

So that's why there's currently no Requires: automake in the spec file.

Note You need to log in before you can comment on or make changes to this bug.