Bug 21873 - up2date failed to see python after installing Linux App Library Workstation and Server Edition CDs
up2date failed to see python after installing Linux App Library Workstation a...
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Preston Brown
Aaron Brown
Depends On:
  Show dependency treegraph
Reported: 2000-12-06 23:41 EST by hocngo
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2000-12-21 14:38:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description hocngo 2000-12-06 23:41:39 EST
Re:  RH22000 - RH Linux 7 - Professional Server (English) RH22000

I had a large hard disk and tried to install on it as much as I could.
First I installed the first 4 CDs. Then CDR0005-1,2 (Linux App. Lib. 
Workstation Ed. CDs).  Then CDR0006-1,2, CDR0007-1: a number of packages 
failed to install because of dependency problem.  Finally I proceeded to 
install the Errata CD.

Following is a screen trace after I inserted the Errata CD and typed:
/mnt/cdr[root@localhost cdrom]# /mnt/cdrom/upgrade-system
error: failed dependencies:
	/usr/bin/python is needed by up2date-2.0.5-3

[root@localhost cdrom]# which python

[root@localhost cdrom]# set | grep PATH

I downloaded from www.redhat.com the latest Errata packages 
up2date-2.0.6-1.i386.rpm and up2date-gnome-2.0.6-1.i386.rpm
but I got basically the same error messages.  I clearly had
python in the path but up2date always complained python
was not found!!!

I contacted RedHat support team for help for several days
but the problem was not resolved.
At last, I crashed my system and reinstalled as follows:
  - installed CDs #1, #2 only
  - then downloaded up2date*.rpm and installed using rpm -ivh successfully
  - then downloaded glibc*.rpm and installed using rpm -Uvh successfully.

I think libraries in CDR0005,6,7 may have been inconsistent with libraries 
in the first two CDS (CD1 and CD2). They may have caused the python 
dependency problem that I experienced.

Can you please duplicate the problem and fix it?
Thank you very much.

Hoc Ngo
Comment 1 Preston Brown 2000-12-08 15:37:44 EST
I'm not sure we can duplicate this problem.  We have tried and failed.  It is
possible that your RPM database became corrupted.

Is the problem resolved for you at this point?
Comment 2 Preston Brown 2001-02-09 00:35:03 EST
closed due to lack of additional reporter feedback and an inability to

Note You need to log in before you can comment on or make changes to this bug.