Bug 218736 - RHNSat5 html/newlogin/create_satellite.pxt missing
RHNSat5 html/newlogin/create_satellite.pxt missing
Status: CLOSED WONTFIX
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
500
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jesus M. Rodriguez
Brandon Perkins
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-06 23:47 EST by Matt Domsch
Modified: 2008-10-29 10:21 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-29 10:21:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Domsch 2006-12-06 23:47:04 EST
Description of problem:
using RHN Satellite 5.0.0 beta

The bug:
/var/www/html/newlogin/index.pxt references a non-existant file
/var/www/html/newlogin/create_satellite.pxt.

On RHN 3.4, I use this to let anyone within my company create their own
satellite server user account, so I don't have to do so for the hundreds of users.  

Please provide a create_satellite.pxt file.

The files provided here are:
/var/www/html/newlogin
/var/www/html/newlogin/.htaccess
/var/www/html/newlogin/index.pxt


Version-Release number of selected component (if applicable):
rhn-satellite-4.9.0-14-redhat-linux-as-i386-4-embedded-oracle.iso
rhn-html-4.9.0-10.rhel4
Comment 1 Matt Domsch 2006-12-07 00:03:21 EST
In addition, newlogin/satellite_finished.pxt is needed.  I snagged a copy of
both these files from my 3.4 installation and they work.

As for creating new admins on the satellite once the first one exists, I had to
modify a few Sniglets and RHN::DB::User files, but that all works great now. :-)
Comment 2 Red Hat Bugzilla 2007-04-11 22:01:30 EDT
User bnackash@redhat.com's account has been closed
Comment 3 Matt Domsch 2008-10-29 10:21:50 EDT
These have been open for years with no investigation or resolution.  Since then the code base has moved on significantly, such that many of these no longer would apply to the current spacewalk code.  I'm closing these requests in the hope they're no longer necessary, or if they are, they'll get discovered anew.

Note You need to log in before you can comment on or make changes to this bug.