Bug 21876 - /etc/pcmcia/network script doesn't execute wireless setup
/etc/pcmcia/network script doesn't execute wireless setup
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2000-12-07 00:33 EST by Perry Harrington
Modified: 2007-04-18 12:30 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2003-06-05 18:38:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Perry Harrington 2000-12-07 00:33:58 EST
The pcmcia-cs package has a wireless startup script which sets various
parameters for wireless ethernet adaptors.  The script /etc/pcmcia/wireless
is not called upon initialization of pcmcia wireless ethernet adaptors.
The problem is that the script /etc/pcmcia/network was modified to use
the redhat standard ifup mechanism without attention to wireless cards.
This bug prevents use of wireless ethernet adaptors in redhat linux.  This
bug affects previous redhat distributions as well (6.2 confirmed).
Included is a diff the /etc/pcmica/network to make wireless support work.

Also, you don't have a separate component listed for kernel-pcmcia-cs
in the bug  tracking system

--- /etc/pcmcia/network	Tue Aug 22 12:58:14 2000
+++ network.pcmcia-wireless	Wed Dec  6 21:34:46 2000
@@ -11,6 +11,21 @@
+if [ -r ./shared ] ; then . ./shared ; else . /etc/pcmcia/shared ; fi
+get_info $device
+HWADDR=`/sbin/ifconfig $device | sed -n -e 's/.*addr \([^ ]*\) */\1/p'`
+if [ -x ./wireless ] ; then
+	. ./wireless
+	. /etc/pcmcia/wireless
 case "${action:?}" in
 	/etc/sysconfig/network-scripts/ifup ifcfg-${device}
Comment 1 Need Real Name 2002-01-31 19:41:25 EST
NOTE:  This bug is in RedHat 7.2 also,

I ran into this one and here's how I solved it:

1- Install the rpm's
You'll need two rpms to get started : 
wireless-tools and kernel-pcmcia-cs.  Either download them from rpmfind.net or
get them from the RH7.2 install cd.  To install just, rpm -ivh <package_name>.

2- Fix /etc/sysconfig/pcmcia
The /etc/init.d/pcmcia rc script tries to source in /etc/sysconfig/pcmcia.   The
default pcmcia file on RH7.2 has some pretty funky options.  I just backed mine
up and changed the options to the following:


Note:  The default pcmcia file had pcmcia turned off, no PCIC setting, and did
not include a line for SCHEME.

3- Fix /etc/pcmcia/network
When the /etc/init.d/pcmcia script runs, you'll see in syslog it does a
./network start eth0 .  That's not /etc/init.d/network start , but instead
/etc/pcmcia/network start .  The problem is by default /etc/pcmcia/network start
does actually nothing.  There's a comment there that reads, "We don't do
*anything* here. We get a hotplug event when the ethX device is registered, and
we bring the device up there". That has never worked for me, thus I changed it.

To get around this bug in the script I have the /etc/pcmcia/network start
actually start the network as one would expect it should.

So I changed the "start" section to read:

     [ -f /etc/sysconfig/network-scripts/ifcfg-${device} ] && \
      /etc/sysconfig/network-scripts/ifup ifcfg-${device}

4- Configure the interface eth0
Since the /etc/pcmcia/network start $device script is going to try to up the
device (default eth0) we need to make sure we have that interface configured for

You can configure eth0 however you want:   netconf, netconfig, linuxconf, or
good old vi.   I prefer to just manually vi the file
/etc/sysconfig/network-scripts/ifcfg-eth0.   Here's what mine looks like:


5- Restart the pcmcia script
From here the configuration should be set for the wireless card to load the
wvlan_cs driver (default setting), and use the "essidany" scheme.
To test it /etc/init.d/pcmcia restart .

Note You need to log in before you can comment on or make changes to this bug.