Bug 21878 - Failures with glibc-2.2-5
Failures with glibc-2.2-5
Status: CLOSED DUPLICATE of bug 21882
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
7.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-07 02:50 EST by Ville Herva
Modified: 2016-11-24 10:21 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-07 02:50:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Herva 2000-12-07 02:50:17 EST
After upgrading to glibc-2.2-5, I get sigsegv's with programs that
worked fine with glibc-2.1.96. For example, rxvt-2.6.3-2 now always 
fails if I select text in it and paste it to _another_ window. The same rxvt binary worked with glibc-2.1.96.

Unfortunately, I can no longer get a gdb traceback from the rxvt.
I got bt's at one point, but now X seems to always kill it before it segfaults:

rxvt: XError: Request: 18 . 0, Error: 16

However, the backtrace was similar to this Opera one:

0x4021ef91 in chunk_alloc (ar_ptr=0x402c1c60, nb=16) at malloc.c:2771
2771    malloc.c: No such file or directory.
(gdb) bt
#0  0x4021ef91 in chunk_alloc (ar_ptr=0x402c1c60, nb=16) at malloc.c:2771
#1  0x4021ed8e in __libc_malloc (bytes=12) at malloc.c:2704
#2  0x400a4a0d in __builtin_new (sz=12) from /usr/lib/libstdc++-libc6.1-1.so.2
#3  0x824fd03 in strcpy () at ../sysdeps/generic/strcpy.c:31
#4  0x8250875 in strcpy () at ../sysdeps/generic/strcpy.c:31
#5  0x8292ad1 in strcpy () at ../sysdeps/generic/strcpy.c:31
#6  0x830288e in strcpy () at ../sysdeps/generic/strcpy.c:31
#7  0x8142c44 in strcpy () at ../sysdeps/generic/strcpy.c:31
#8  0x86a8930 in ?? ()

(Opera has also begun to segfault at start after glibc upgrade).

I compiled rxvt-2.6.3 from source, and it exhibits the same behaviour. Devel version 2.7.2 does not crash, but it corrupts the selection.

Other X programs still work fine wrt X selection.
Comment 1 Daniel Roesen 2000-12-07 07:04:38 EST

*** This bug has been marked as a duplicate of 21882 ***

Note You need to log in before you can comment on or make changes to this bug.