Bug 218797 - Kernel panics when switching from run level 5 to any other runlevel
Kernel panics when switching from run level 5 to any other runlevel
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks: 427887
  Show dependency treegraph
 
Reported: 2006-12-07 11:00 EST by Tom Diehl
Modified: 2008-01-08 10:23 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-08 10:23:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output from netconsole when kernel panics. (2.96 KB, text/plain)
2006-12-18 21:04 EST, Tom Diehl
no flags Details
This is the output from a panic while running yum update. (6.28 KB, application/octet-stream)
2006-12-18 23:36 EST, Tom Diehl
no flags Details
Kernel panic after installing all updates. (5.96 KB, application/octet-stream)
2006-12-18 23:37 EST, Tom Diehl
no flags Details

  None (edit)
Description Tom Diehl 2006-12-07 11:00:24 EST
Description of problem: When switching from runlevel 5 to any other runlevel the
kernel panics. This only occurs when the machine is in runlevel 5. If I bring
the machine up in runlevel 3 and then switch to runlevel 6 it reboots normally.


Version-Release number of selected component (if applicable):
[root@tigger2 ~]# uname -r
2.6.18-1.2849.fc6

xorg-x11-server-Xorg-1.1.1-47.1.fc6

[root@tigger2 log]# cat /proc/cpuinfo
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 15
model           : 6
model name      :               Intel(R) Pentium(R) 4 CPU 3.40GHz
stepping        : 4
cpu MHz         : 3391.589
cache size      : 2048 KB
physical id     : 0
siblings        : 2
core id         : 0
cpu cores       : 1
fpu             : yes
fpu_exception   : yes
cpuid level     : 6
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov
pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm syscall lm constant_tsc
pni monitor ds_cpl est tm2 cid cx16 xtpr lahf_lm
bogomips        : 6786.42
clflush size    : 64
cache_alignment : 128
address sizes   : 36 bits physical, 48 bits virtual
power management:

[root@tigger2 log]#

The machine is an HP DC5100 with a fresh install of FC6 and all of the updates
applied.

How reproducible: every time I try to switch runlevels from RL 5


Steps to Reproduce:
1.boot machine into runlevel 5
2. type init 6 on a command line or press <ctrl><alt><del>
3.
  
Actual results:
Kernel panics

Expected results:
Normal reboot

Additional info: On one of the panics I saw the following message:
BUG: Spinlock recursion on CPU 0, XORG/2644 (Not Tainted).

Ths is a new machine and install of FC6.

Please let me know what other information would be useful in debugging this.

I do not see anything unusual in the logs.
Comment 1 Tom Diehl 2006-12-07 17:57:15 EST
FYI, I updated the kernel to 2.6.18-1.2860.fc6. 

No change in behavior
Comment 2 Tom Diehl 2006-12-18 21:04:20 EST
Created attachment 143976 [details]
Output from netconsole when kernel panics.
Comment 3 Tom Diehl 2006-12-18 23:36:08 EST
Created attachment 143978 [details]
This is the output from a panic while running yum update.

This dump was captured while running yum update via netconsole.
Comment 4 Tom Diehl 2006-12-18 23:37:50 EST
Created attachment 143979 [details]
Kernel panic after installing all updates.

This panic was captured after all updates were installed and the machine was
rebooted. The panic was captured via netconsole.
Comment 5 Tom Diehl 2006-12-18 23:43:02 EST
The panics occur when the machine is loaded with the x86_64 version of FC6. I
reloaded the machine with the i386 version and the machine operated normally.

Also fixed spelling error in the summary.
Comment 6 Dhaval Giani 2007-01-24 10:22:46 EST
I too have a similar problem. My system runs a FC6, x86_64.

My /proc/cpuinfo is

[dhaval@localhost installs]$ cat /proc/cpuinfo 
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 15
model name      : Intel(R) Core(TM)2 CPU          6300  @ 1.86GHz
stepping        : 6
cpu MHz         : 1862.000
cache size      : 2048 KB
physical id     : 0
siblings        : 2
core id         : 0
cpu cores       : 2
fpu             : yes
fpu_exception   : yes
cpuid level     : 10
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov
pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm syscall lm constant_tsc
pni monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr lahf_lm
bogomips        : 3728.47
clflush size    : 64
cache_alignment : 64
address sizes   : 36 bits physical, 48 bits virtual
power management:

processor       : 1
vendor_id       : GenuineIntel
cpu family      : 6
model           : 15
model name      : Intel(R) Core(TM)2 CPU          6300  @ 1.86GHz
stepping        : 6
cpu MHz         : 1862.000
cache size      : 2048 KB
physical id     : 0
siblings        : 2
core id         : 1
cpu cores       : 2
fpu             : yes
fpu_exception   : yes
cpuid level     : 10
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov
pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm syscall lm constant_tsc
pni monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr lahf_lm
bogomips        : 3724.19
clflush size    : 64
cache_alignment : 64
address sizes   : 36 bits physical, 48 bits virtual
power management:

[dhaval@localhost installs]$ 

My panic though had some ext3 and vfs functions in the trace. If someone can
tell me how to use netconsole, I can get the panic details. It is more than once
screenful.

To cause this panic, I did the following.
1. Boot into init 3
2. Run startx
3. press ^c in the console where i started startx.

BTW, the system hangs when I shutdown. My guess was it is because of the panic.
Comment 7 Dhaval Giani 2007-01-24 10:52:56 EST
[dhaval@localhost ~]$ uname -r
2.6.18-1.2798.fc6
[dhaval@localhost ~]$ 
Comment 8 Jon Stanley 2008-01-07 20:49:58 EST
(This is a mass-update to all current FC6 kernel bugs in NEW state)

Hello,

I'm reviewing this bug list as part of the kernel bug triage project, an attempt
to isolate current bugs in the Fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug, however this version of Fedora is no longer
maintained.

Please attempt to reproduce this bug with a current version of Fedora (presently
Fedora 8). If the bug no longer exists, please close the bug or I'll do so in a
few days if there is no further information lodged.

Thanks for using Fedora!
Comment 9 Tom Diehl 2008-01-08 10:23:11 EST
This problem was resolved during the F7 Beta cycle.

Note You need to log in before you can comment on or make changes to this bug.