Bug 2188 - Config files should be in /etc
Summary: Config files should be in /etc
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: mc
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact:
URL:
Whiteboard:
: 69943 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-04-15 06:37 UTC by Marc MERLIN
Modified: 2013-07-02 22:54 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-28 11:23:01 UTC


Attachments (Terms of Use)
Patch to make mc FHS compliant. (12.04 KB, patch)
2006-02-24 14:39 UTC, Jindrich Novy
no flags Details | Diff

Description Marc MERLIN 1999-04-15 06:37:34 UTC
I'm filling this on slrn, but other packages are affected:
at least rpm (/usr/lib/rpm/rpmrc), midnight commander
(/usr/lib/mc/mc.{ini,lib}), lynx (/usr/lib/lynx.cfg),
and possibly others.

The FHS says that config files should be in /etc, and you've
fixed most packages to respect this rule, but a few
(including the ones mentionned above) are missing.

Comment 1 Bill Nottingham 1999-04-15 13:54:59 UTC
lynx at least has been fixed in 5.9

Comment 2 Cristian Gafton 1999-06-18 16:43:59 UTC
Those are not config files. You can override /usr/lib/rpm/rpmrc in
/etc/rpmrc if you want.

Comment 3 Marc MERLIN 2003-04-29 04:33:35 UTC
mc is still not fixed, 4 years later :-(
Neither is vim...

You are still putting mc config files outside of /etc/mc (/usr/share/mc).
Vim is also still equally broken and doesn't look for its config in /etc/vim

Comment 4 Karsten Hopp 2003-08-12 10:48:03 UTC
vim is fixed, mc still needs fixing 

Comment 5 Jakub Jelinek 2004-10-07 12:08:38 UTC
I wouldn't move the whole /usr/share/mc hierarchy, just 
/usr/share/mc/cedit.menu
/usr/share/mc/edit.indent.rc
/usr/share/mc/edit.spell.rc
/usr/share/mc/mc.ext
/usr/share/mc/mc.lib
/usr/share/mc/mc.menu

to /etc/mc/
It will need source changes so that those config files are first looked up
in /etc/mc/ and only when not found searched in /usr/share/mc.

Comment 6 Jindrich Novy 2004-10-30 09:14:36 UTC
*** Bug 69943 has been marked as a duplicate of this bug. ***

Comment 7 Jindrich Novy 2006-02-24 14:39:30 UTC
Created attachment 125177 [details]
Patch to make mc FHS compliant.

So finally here we go with the patch. I'll send it upstream as well.

Comment 8 Jindrich Novy 2006-02-25 12:29:29 UTC
Fixed in mc-4.6.1a-8.

Comment 9 Leonard den Ottolander 2006-02-27 21:37:33 UTC
Fix is incomplete and breaks syntax highlighting. /home/<user>/.mc/cedit/Syntax
cannot be found. Adding /etc/mc/syntax/Syntax fixes the issue.


Comment 10 Jindrich Novy 2006-02-28 11:22:36 UTC
Ok, reproduced and fixed. It was only a packaging problem fixed in spec. Thanks
for testing.

Comment 11 Fedora Update System 2006-03-07 16:36:40 UTC
From User-Agent: XML-RPC

mc-4.6.1a-5.fc4 has been pushed for FC4, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.