Bug 218803 - Serial Acecat III tablet doesn't work
Serial Acecat III tablet doesn't work
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-acecad (Show other bugs)
8
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-07 11:29 EST by Kevin R. Page
Modified: 2009-01-09 02:02 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-09 02:02:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin R. Page 2006-12-07 11:29:09 EST
This is a serial port Acecat III tablet - which has worked in the past (a couple
of years ago, perhaps 2.4 era kernels), but isn't any more. I've checked that
the hardware functions under a different operating system, and it does.

If I cat /dev/ttyS0 I get data when I put the pen to the tablet.

Section from my xorg.conf (I've also tried changing "Model" to no effect, and
various values of "ReportSpeed"):

Section "InputDevice"
        Identifier  "Tablet0"
        Driver      "acecad"
        # Absolute or Relative (I don't have test Relative yet)
        Option "Mode" "Absolute"
        # Model can be Flair or A-Series
        Option "Model" "A-Series"
        # You can choose report speed between 2, 10, 85 and 120
report/second.
        # 120 is very fine but need a lot of CPU.
        Option "ReportSpeed" "10"
        # This lets you choose how the buttons are mapped. Only tested
for
        # A-Series model. Choices are Standard or Acecad
        Option "ButtonMap" "Acecad"
        # Choose your port
        Option      "Device" "/dev/ttyS0"
EndSection



and the error from Xorg.0.log:

(**) Option "Device" "/dev/ttyS0"
(**) Option "BaudRate" "9600"
(**) Option "StopBits" "1"
(**) Option "DataBits" "8"
(**) Option "Parity" "Odd"
(**) Option "Vmin" "1"
(**) Option "Vtime" "10"
(**) Option "FlowControl" "Xoff"
(**) Option "ReportSpeed" "85"
(**) Acecad Tablet report 85 points/s
(EE) Unable to query/initialize AceCad hardware.
(EE) PreInit returned NULL for "Tablet0"
Comment 1 Matěj Cepl 2007-12-10 04:24:13 EST
Fedora Core 6 is no longer supported, could you please reproduce this with the
updated version of the currently supported distribution (Fedora 7, 8, or
Rawhide)? If this issue turns out to still be reproducible, please let us know
in this bug report. If after a month's time we have not heard back from you, we
will have to close this bug as CANTFIX.

Setting status to NEEDINFO, and awaiting information from the reporter.

[This is mass-filed message to all open Fedora Core 6 bugs related to Xorg or
Gecko. If you see any other reason, why this bug shouldn't be closed, please,
comment on it here.]
Comment 2 Kevin R. Page 2007-12-10 16:52:40 EST
Hardware still fails with xorg-x11-drv-acecad-1.1.0-5.fc8

Admittedly, I've given up using this hardware as it no longer works.
Comment 3 Matěj Cepl 2007-12-11 05:39:24 EST
Do you have still hardware available? Are you willing to reproduce the bug and
help us with debugging, or should I close this as INSUFFICIENT_DATA. Sorry, I
just not grok your comment 2 completely.
Comment 4 Kevin R. Page 2007-12-11 05:58:54 EST
I still have access to the hardware - I tested it with F8 yesterday (the
Xorg.log was the same as comment #0, fwiw) - and I'm willing to test/run debug
builds. As far as I'm aware the hardware is still working - it's untouched since
last tested a year ago, when it worked under Windows; I no longer have the
capability to test using Windows. I still get output if I cat /dev/ttyS0.

(re: comment #2, I merely meant that since the driver hasn't worked for over a
year, I haven't been able to use it! Sorry for being unclear.)
Comment 5 Bug Zapper 2008-11-26 02:07:02 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Bug Zapper 2009-01-09 02:02:13 EST
Fedora 8 changed to end-of-life (EOL) status on 2009-01-07. Fedora 8 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.