Bug 218809 - RHNSat package lookaside from a previous satellite install
RHNSat package lookaside from a previous satellite install
Status: CLOSED WONTFIX
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
500
All Linux
low Severity medium
: ---
: ---
Assigned To: Jesus M. Rodriguez
Brandon Perkins
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-07 12:13 EST by Matt Domsch
Modified: 2008-10-29 10:21 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-29 10:21:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
satsync-lookaside.patch (1.88 KB, patch)
2006-12-07 12:13 EST, Matt Domsch
no flags Details | Diff

  None (edit)
Description Matt Domsch 2006-12-07 12:13:47 EST
Description of problem:
To populate an RHN Satellite with thousands of RPMs (mine has >40k) you must
either a) download them all over the WAN (slow and expensive), or b) download a
metric ton of content CDs, explode them, then import them (which is slow,
expensive, and requires 2X the disk space to accomplish).  As I already had a
satellite server with a 120GB of /var/satellite packages, why couldn't
satellite-sync use those?

So, here's a hackish patch to add a package lookaside.  When it wants to
download an RPM, it can look in /mnt/satellite and see if the package exists
there.  If so, don't download it but just use the "local" copy.  This sped up my
syncing from *days* to *minutes*.

Please consider something along these lines for future Satellite releases.  This
patch is a hack that works, but would be good to be a command line option,
specifying the dir (instead of hard-coding /mnt/satellite).

Version-Release number of selected component (if applicable):
RHN5
Comment 1 Matt Domsch 2006-12-07 12:13:47 EST
Created attachment 143067 [details]
satsync-lookaside.patch
Comment 2 Red Hat Bugzilla 2007-04-11 22:01:56 EDT
User bnackash@redhat.com's account has been closed
Comment 3 Matt Domsch 2008-10-29 10:21:51 EDT
These have been open for years with no investigation or resolution.  Since then the code base has moved on significantly, such that many of these no longer would apply to the current spacewalk code.  I'm closing these requests in the hope they're no longer necessary, or if they are, they'll get discovered anew.

Note You need to log in before you can comment on or make changes to this bug.