Bug 21881 - rpm dependency problems when rpms fail to install.
Summary: rpm dependency problems when rpms fail to install.
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 6.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-12-07 09:21 UTC by Need Real Name
Modified: 2007-04-18 16:30 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-03 12:13:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2000-12-07 09:21:49 UTC
If you try and install 2 RPMS, let's say x.rpm and y.rpm and y depends on x
then you might use the command:

rpm -i x.rpm y.rpm

However, if installation of x fails (in the tested case it failed due to an
error in the pre installation script) then y is still installed.  You then
have package y installed, but it's dependency x isn't.

Comment 1 Jeff Johnson 2000-12-22 14:57:39 UTC
Yup, that's the behavior that is implemented to the best of my knowledge. 

A "fix" is non-trivial, and is gonna take a while, so I'm marking as Deferred.

Comment 2 Jeff Johnson 2002-11-22 15:06:02 UTC
Detecting all %pre failures before any
package is installed would be very nice to
do, but cannot be done without reworking
rpm's install state machine. Not gonna happen
soon, may never happen.


Note You need to log in before you can comment on or make changes to this bug.