Bug 218811 - Evolution RPM does not record dependency on gnome-themes for icons
Evolution RPM does not record dependency on gnome-themes for icons
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
6
i386 Linux
low Severity low
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-07 12:25 EST by Dale R. Worley
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-04 23:47:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dale R. Worley 2006-12-07 12:25:16 EST
Description of problem:

Evolution (evolution-2.6.3-1.fc5.5) uses files from the gnome-themes RPM to
provide icons, but the evolution-2.6.3-1.fc5.5 RPM contains no dependency on
gnome-themes.

Version-Release number of selected component (if applicable):

2.6.3

How reproducible:

Reliably

Steps to Reproduce:
1. Do a minimal installation of FC 5, being careful to not install any more of
Gnome than necessary.
2. Install Evolution.
3. Run Evolution.
  
Actual results:

The Send/Receive, Reply, Forward, etc. buttons in the mail-reading screen will
show a red-X "can't find icon" icon.

Evolution will also produce error messages on stdout and/or stderr.

If you then install gnome-themes, proper icons will appear.

Expected results:

The Evolution icons show show without any additional installation steps.

Additional info:

None
Comment 1 Matthew Barnes 2006-12-07 13:20:46 EST
Please try again with Evolution 2.8.2.1 in Fedora Core 6.

Evolution 2.6.3 is no longer supported.
Comment 2 Stefan Becker 2007-06-14 11:22:54 EDT
The bug is also (reappeared?) in F7:

$ rpm -q evolution
evolution-2.10.2-2.fc7
$ rpm -q evolution --requires | fgrep theme
gnome-icon-theme >= 1.3.6

Only after installing

$ rpm -q gnome-themes
gnome-themes-2.18.0-1.fc7

by hand all those red X icons are replaced with real ones...
Comment 3 Matthew Barnes 2007-10-04 23:47:51 EDT
Fixed in evolution-2.12.0-5.fc8.

Note You need to log in before you can comment on or make changes to this bug.