Bug 218821 - CVE-2006-6235: gnupg2 <= 2.0.1 stack overwrite vulnerability
CVE-2006-6235: gnupg2 <= 2.0.1 stack overwrite vulnerability
Product: Fedora
Classification: Fedora
Component: gnupg2 (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
: Security
Depends On:
  Show dependency treegraph
Reported: 2006-12-07 13:16 EST by Ville Skyttä
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.0.1-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-12-07 13:25:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2006-12-07 13:16:46 EST

"A "stack overwrite" vulnerability in GnuPG (gpg) before 1.2.1 allows attackers
to execute arbitrary code via crafted OpenPGP packets that cause GnuPG to
dereference a function pointer from deallocated stack memory."

FC6+ seem to be taken care of already, FC-[345] not yet.
Comment 1 Rex Dieter 2006-12-07 13:25:37 EST
Right FC-6+ build pushed yesterday already.

* Wed Dec 06 2006 Rex Dieter <rexdieter[AT]users.sf.net> 2.0.1-2
- CVE-2006-6235 (bug #218821)

Older releases don't include the gpg2 (and friends) binaries, so they aren't
(shouldn't!) be affected by this.
Comment 2 Ville Skyttä 2006-12-07 15:04:28 EST
Seems so indeed.

Note You need to log in before you can comment on or make changes to this bug.