Bug 21888 - Cant run applix or word perfect 8 due to library problem
Summary: Cant run applix or word perfect 8 due to library problem
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: compat-libs   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matt Wilson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-12-07 12:16 UTC by Jim Nance
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-07 12:16:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jim Nance 2000-12-07 12:16:21 UTC
I am unable to run applix or wordperfect 8 because of shared library
problems.  It works
under RedHat 6.2 because the libc-5.3.12-31 package supplies those libs:

bessie> cd /opt/applix/
bessie> ldd ./applix 
        libX11.so.6 => /usr/i486-linux-libc5/lib/libX11.so.6 (0x4000d000)
        libm.so.5 => /usr/i486-linux-libc5/lib/libm.so.5 (0x4009f000)
        libc.so.5 => /usr/i486-linux-libc5/lib/libc.so.5 (0x400a7000)
bessie> file ./applix 
./applix: ELF 32-bit LSB executable, Intel 80386, version 1, dynamically
linked (uses shared libs), not stripped
bessie> rpm -qf /usr/i486-linux-libc5/lib/libm.so.5.0.6 
libc-5.3.12-31

This package does not exist under 7.0.  The closest I can find is
compat-glibc-6.2-2.1.3.2
but this does not contain the necessary files.

Comment 1 Bill Nottingham 2000-12-07 16:34:31 UTC
Install the libc and ld.so packages from 6.2.

libc5 support was intentionally removed.


Note You need to log in before you can comment on or make changes to this bug.