Bug 218889 - evolution-devel should require evolution-data-server-devel
evolution-devel should require evolution-data-server-devel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-07 19:34 EST by Michel Alexandre Salim
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: evolution-2.9.4-4.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-30 20:39:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michel Alexandre Salim 2006-12-07 19:34:53 EST
Description of problem:
evolution-devel includes evolution-plugin-2.8.pc, which depends on
camel-provider-1.2.pc which is provided by evolution-data-server-devel. It does
not depend on it, though, which causes Evolution plugins to be unbuildable in
mock if they don't BR: on evolution-data-server-devel


Version-Release number of selected component (if applicable):
evolution-devel-2.8.2.1-2.fc6


How reproducible:
Always


Steps to Reproduce:
1. rpm -q --requires evolution-devel | grep evolution-data-server
  
Actual results:
No requirement found
Comment 1 Matthew Barnes 2006-12-30 09:40:42 EST
Thanks for the bug report.

Looks like this is also the case in the latest Rawhide package.

Changing version to 'devel', but I'll backport the fix to FC-6.
Comment 2 Matthew Barnes 2006-12-30 20:39:10 EST
Fixed in evolution-2.9.4-4.fc7 and evolution-2.8.2.1-3.fc6.

Note You need to log in before you can comment on or make changes to this bug.