Bug 218912 - Compiling with gcc296.
Compiling with gcc296.
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: compat-gcc-296 (Show other bugs)
3.7
All Linux
medium Severity high
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-08 05:06 EST by Andrew
Modified: 2007-11-16 20:14 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-08 14:47:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
all output after make command (6.65 KB, text/plain)
2006-12-08 05:06 EST, Andrew
no flags Details

  None (edit)
Description Andrew 2006-12-08 05:06:05 EST
I have install RHEL3 up 7 with all RPMs.

I have application which have to be compiled with a help of compat-glibc RPM.
I define LDFLAGS=-I/usr/lib/i386-redhat-linux7/include
-L/usr/lib/i386-redhat-linux7/lib
I relink /usr/bin/gcc to /usr/bin/gcc296 and tried to compile this application.
I've get an error:
=========================
/usr/lib/gcc-lib/i386-redhat-linux7/2.96/../../../crt1.o(.text+0xc): In function
`_start':
: undefined reference to `__libc_csu_fini'
/usr/lib/gcc-lib/i386-redhat-linux7/2.96/../../../crt1.o(.text+0x11): In
function `_start':
: undefined reference to `__libc_csu_init'
/app/oracle/product/8.0.5//lib/libclntsh.so: undefined reference to
`sys_nerr@GLIBC_2.3'
/app/oracle/product/8.0.5//lib/libclntsh.so: undefined reference to
`sys_errlist@GLIBC_2.3'
=========================

As I understand right the problem with linking of /usr/lib/libc.a or
/usr/lib/libc_nonshared.a.

I've attached main part of log. Could you help me?
Comment 1 Andrew 2006-12-08 05:06:05 EST
Created attachment 143138 [details]
all output after make command
Comment 2 Jakub Jelinek 2006-12-08 14:47:12 EST
The first 2 errors are because -B/usr/lib/i386-redhat-linux7/lib/
wasn't passed to the compiler driver, so that it picks up glibc-2.2.4 crtfiles
(crt*.o) as opposed to glibc 2.3.2.

The second two errors just show that you can't link against compat-glibc
if any of the libraries have been linked against a newer glibc.
So, either you compile/link /app/oracle/product/8.0.5//lib/libclntsh.so
against compat-glibc and then you can compile/link your program against
compat-glibc too (note, -I/usr/lib/i386-redhat-linux7/include/ in LDFLAGS
is wrong, you need that in CFLAGS, so that all sources are using compat-glibc
headers).

Note You need to log in before you can comment on or make changes to this bug.