Bug 2189205 - Visual mode not working
Summary: Visual mode not working
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: rstudio
Version: 38
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Iñaki Ucar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2023-04-24 12:29 UTC by cmmrandau
Modified: 2023-05-03 03:01 UTC (History)
3 users (show)

Fixed In Version: rstudio-2023.03.0+386-4.fc38 rstudio-2023.03.0+386-4.fc37
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-04-28 02:36:09 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description cmmrandau 2023-04-24 12:29:03 UTC
Visual (markdown) mode does not work, only displays a spinning cog wheel. The official version from the rstudio website installed with rpm works. 

Reproducible: Always

Steps to Reproduce:
1. Install rstudio from official repos
2. Create a new .rmd file
3. Enter visual mode
Actual Results:  
Visual mode does not work

Expected Results:  
Visual mode shall work

Comment 1 Iñaki Ucar 2023-04-24 16:21:24 UTC
Thanks for the report. Is there any info in the logs that could help us? (in Help > Diagnostics)

Comment 2 Iñaki Ucar 2023-04-24 17:23:08 UTC
I reproduced this, and I found a couple of error messages in the logs myself. Let's see if upstream can help us: https://github.com/rstudio/rstudio/issues/13042

Comment 3 Fedora Update System 2023-04-24 21:19:56 UTC
FEDORA-2023-bac79b24e3 has been submitted as an update to Fedora 38. https://bodhi.fedoraproject.org/updates/FEDORA-2023-bac79b24e3

Comment 4 Fedora Update System 2023-04-24 21:20:17 UTC
FEDORA-2023-654e32b78f has been submitted as an update to Fedora 37. https://bodhi.fedoraproject.org/updates/FEDORA-2023-654e32b78f

Comment 5 Iñaki Ucar 2023-04-24 21:21:14 UTC
I think I found the solution, or at least it works for me. Please could you test the update above?

Comment 6 cmmrandau 2023-04-24 21:33:21 UTC
Cheers, it's working! <:D

Comment 7 Fedora Update System 2023-04-25 03:21:36 UTC
FEDORA-2023-bac79b24e3 has been pushed to the Fedora 38 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-bac79b24e3`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-bac79b24e3

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 8 Fedora Update System 2023-04-25 03:27:04 UTC
FEDORA-2023-654e32b78f has been pushed to the Fedora 37 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-654e32b78f`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-654e32b78f

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 9 Fedora Update System 2023-04-28 02:36:09 UTC
FEDORA-2023-bac79b24e3 has been pushed to the Fedora 38 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 10 Fedora Update System 2023-05-03 03:01:27 UTC
FEDORA-2023-654e32b78f has been pushed to the Fedora 37 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.