Bug 218943 - initng gets locked cause of selinux
initng gets locked cause of selinux
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: initng (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Malmgren
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-08 11:57 EST by Andrea Santilli
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-05 05:09:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrea Santilli 2006-12-08 11:57:59 EST
Description of problem:
i wanted to try initng so i installed it and reboot.

but the booting process got locked at 8%.
the problem is that system/selinux/dev wont boot.
i tried switching selinux to permissive mode but initng still got locked.
i also tried to completely disable selinux but the result is the same.

so i press CTRL+D when it gets locked but still after a while it tries to run
system/selinux/relabel.
of course it gets locked again.

the i press CTRL+D again, and it reaches the login.

but after a while i get some error saying that smartd, dhcdbd and NetworkManager
cant start. at least until i run them with the /sbin/service utility.


Version-Release number of selected component (if applicable):
0.6.8-9.fc6

How reproducible:
always

Steps to Reproduce:
1.install initng
2.reboot to an initng grub entry
3.it gets locked at system/selinux/dev and system/selinux/relabel
4.smartd, dhcdbd and NetworkManager cant start
Comment 1 Daniel Malmgren 2006-12-12 05:29:13 EST
What happens if you clean out all selinux stuff from the runlevels? Check
/etc/initng/default.runlevel and /etc/initng/system.virtual and remove all lines
starting with system/selinux. That's the best test I can come up with right now.

Since I don't know much about selinux I'll add Dragoran to cc list of this bug,
hoping he might have any good ideas...
Comment 2 drago01 2006-12-12 13:48:52 EST
yes try disabling it for now I am a bit busy now will look at it this weekend.
Comment 3 Andreas Øye 2006-12-20 18:52:55 EST
how is the check_selinux supposed to work?

service system/selinux/dev {
        need = system/initial/mountvirtfs;
        script start = {
                check_selinux() {
                        while read dev mp fs stuff
                        do
                                [ "$fs" = "selinuxfs" ] && echo "$mp"
                        done
                }
                # Check SELinux status
                selinuxfs=`/bin/awk '$3=="selinuxfs" {print $2}' /proc/mounts`
                #selinuxfs=`check_selinux`
                echo "selinuxfs is $selinuxfs"

Replacing check_selinux call with the oldschool awk grep from proc mounts allows
it to proceed past this. Where does check_selinux know how to read from
/proc/mounts? got some hald weirdness with selinux, but dunno what that is yet. 
Comment 4 Daniel Malmgren 2007-02-05 05:09:16 EST
There are now new upstreams versions of both initng and initng-ifiles in Fedora
extras. I have no idea if this bug is solved, but let's hope it is ;-)

I'll close this bug, please reopen it if the error is still there.

Note You need to log in before you can comment on or make changes to this bug.