Bug 2189779 - Certbot broken logrotate config
Summary: Certbot broken logrotate config
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: certbot
Version: 38
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Nick Bebout
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 2188888 2196624 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2023-04-26 06:43 UTC by olegon.ru
Modified: 2023-05-22 18:17 UTC (History)
8 users (show)

Fixed In Version: certbot-2.5.0-3.fc38 certbot-2.5.0-3.el9
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-04-28 02:36:50 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description olegon.ru 2023-04-26 06:43:22 UTC
certbot installs non-config file in /etc/logrotate.d/certbot

Reproducible: Always

Steps to Reproduce:
dnf install certbot
cat /etc/logrotate.d/certbot




I saw errors in logrotate journal. This is very strange idea to place this file here :) I supposed to be hacked...

Comment 1 Rob Thijssen 2023-04-27 12:27:01 UTC
see: https://bugzilla.redhat.com/show_bug.cgi?id=2187543

Comment 2 Fedora Update System 2023-04-27 12:54:16 UTC
FEDORA-EPEL-2023-355404d2b1 has been submitted as an update to Fedora EPEL 9. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2023-355404d2b1

Comment 3 Fedora Update System 2023-04-27 12:54:16 UTC
FEDORA-2023-9b2f8e3e49 has been submitted as an update to Fedora 38. https://bodhi.fedoraproject.org/updates/FEDORA-2023-9b2f8e3e49

Comment 4 Fedora Update System 2023-04-27 12:54:17 UTC
FEDORA-2023-98f6be7e17 has been submitted as an update to Fedora 37. https://bodhi.fedoraproject.org/updates/FEDORA-2023-98f6be7e17

Comment 5 Jonathan Wright 2023-04-27 12:59:05 UTC
*** Bug 2188888 has been marked as a duplicate of this bug. ***

Comment 6 Jonathan Wright 2023-04-27 12:59:49 UTC
Please check the update in https://bodhi.fedoraproject.org/updates/?search=certbot-2.5.0-3, test the packages, and provide karma as applicable so we can get this fix to stable repos faster.

Comment 7 Fedora Update System 2023-04-28 02:36:50 UTC
FEDORA-2023-9b2f8e3e49 has been pushed to the Fedora 38 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 8 Fedora Update System 2023-04-28 02:40:30 UTC
FEDORA-EPEL-2023-355404d2b1 has been pushed to the Fedora EPEL 9 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 9 Jonathan Wright 2023-05-22 18:17:10 UTC
*** Bug 2196624 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.