This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 218999 - vncserver throws cairo errors with some applications
vncserver throws cairo errors with some applications
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: vnc (Show other bugs)
6
All Linux
medium Severity high
: ---
: ---
Assigned To: Adam Tkac
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-08 18:22 EST by Bevan Bennett
Modified: 2013-04-30 19:34 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-13 03:41:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bevan Bennett 2006-12-08 18:22:20 EST
Description of problem: 
Under 4.1.2-7.fc6 vncserver, attempting to display certain visuals throws cairo
errors and crashes window managers.  The applications in question run fine under
the standard console X, but crash under the new vnc-server.


Version-Release number of selected component (if applicable): 4.1.2-7.fc6
Problem does not exist with version 4.1.2-3.fc6.

How reproducible: 


Steps to Reproduce:
1. vncserver :2 --depth 24
2. vncviewer :2
3. inside vnc, launch a specific app. (Apologies, the one reliable cause I'v
found is the Cadence Library Manager, which we license. Other causes might be
able to be found from the type of cairo error -- see below.)
  
Actual results: 
New window comes up with mangled colormap.
Metacity (if running on the VNC desktop) crashes.
VNC log reports error listed below.

Expected results:
New window comes up with correct colormap, no window manager crashes.

Additional info: 
The error thrown is:
Window manager warning: Log level 16: gdkpixbuf-drawable.c:1247: Source drawable
has no colormap; either pass in a colormap, or set the colormap on the drawable
with gdk_drawable_set_colormap()
Error: Cairo 1.2.6 does not yet support the requested image format:
        Depth: 32
        Alpha mask: 0x00000000
        Red   mask: 0xffe00000
        Green mask: 0x001ffc00
        Blue  mask: 0x000003ff
Please file an enhancement request (quoting the above) at:
http://bugs.freedesktop.org/enter_bug.cgi?product=cairo
metacity: cairo-image-surface.c:201: _cairo_format_from_pixman_format: Assertion
`NOT_REACHED' failed.

Internal testing shows that this behavior occurs only with the newer vnc-server
package and occurs with both cairo 1.2.4 and 1.2.6.
Comment 1 Adam Tkac 2006-12-11 05:07:52 EST
Could you send me name of package with affected application? I can't reproduce
this bug with "standard" cairo apps (gnome's system-config-* utilities) Thanks much
Comment 2 Bevan Bennett 2006-12-11 12:04:55 EST
The only app that is doing this reliably for us is proprietary, licensed software:
Cadence IC 51.41, specifically the Library Manager.

I believe it does use some weird color mode, and it refuses to run if it doesn't
detect either a 8bit or 24bit display.
Comment 3 Adam Tkac 2006-12-12 05:49:28 EST
(In reply to comment #2)
> The only app that is doing this reliably for us is proprietary, licensed software:
> Cadence IC 51.41, specifically the Library Manager.
> 
> I believe it does use some weird color mode, and it refuses to run if it doesn't
> detect either a 8bit or 24bit display.

It is big problem because cairo doesn't support 8bit depth (vncserver yes) and
vnc-server doesn't support 24bit per pixel. Both of these enhancements are known
in upstreams. You said that problem doesn't exists with vnc-server-4.1.2-3.fc6?
Try run vncserver with option "-render" ($ vncserver :2 -render) Does it works now?
Comment 4 Bevan Bennett 2006-12-12 18:22:04 EST
vnc-server-4.1.2-3.fc6 works fine.
vnc-server-4.1.2-7.fc6 throws a fit.

Hey! "-render" makes 4.1.2-7.fc6 work as well. What does that option do? 
I can't find it documented in "man vncserver" or "man Xvnc"...

Is there an easy way to set this as a global default?
Comment 5 Adam Tkac 2006-12-13 03:41:58 EST
(In reply to comment #4)
> vnc-server-4.1.2-3.fc6 works fine.
> vnc-server-4.1.2-7.fc6 throws a fit.
> 
> Hey! "-render" makes 4.1.2-7.fc6 work as well. What does that option do? 
> I can't find it documented in "man vncserver" or "man Xvnc"...
> 
> Is there an easy way to set this as a global default?

Yes, render I'm going to set this option by default because this bug isn't first  
problem with it

Note You need to log in before you can comment on or make changes to this bug.