Bug 219 - Error with swapon in rc.sysinit when swap is on a device handled by kerneld
Error with swapon in rc.sysinit when swap is on a device handled by kerneld
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
5.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1998-11-28 19:57 EST by Marc MERLIN
Modified: 2014-03-16 22:08 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1998-12-05 23:51:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marc MERLIN 1998-11-28 19:57:03 EST
This is an old bug forwarded to your new bug tracking system

If you configure fstab to use a swap partition on a device
that is only available after kerneld is run (let's say a
SCSI disk), the initial swapon command
outputs:
swapon: /dev/devname: Device not
configured

It is not a big problem the script does a second swapon -a
later, but it'd be nice to get rid of the error
message

The first swapon should be replaced
with:
swapon -a 2>&1 | grep -v "Device not configured"
Comment 1 Marc MERLIN 1998-11-28 20:04:59 EST
Fixed summary to say "Error with swapon in rc.sysinit when swap is on
a device handled by kerneld" (quoted here just in case bugzilla
doesn't let me change it)
Comment 2 David Lawrence 1998-11-29 20:26:59 EST
This is a valid point. Was this a device or swap partition that was
added after the initial installation? If it is then the initrd.img is
possible not loading the support for the device the swap file is one
because the install creates the initial initrd.img file according to
the hardware it detects (or you choose) during the installtion. You
can create a new initrd.img with support for your new card and replace
your current one. This should allow the first swapon -a to work. If
this is not the case then your suggestion should also work.
Comment 3 Marc MERLIN 1998-11-30 04:40:59 EST
You are correct, the swap device was added by hand, after RH was
installed. The kernel was custom compiled (without initrd), so that's
why the scsi module is loaded later (the system boots on IDE).
I hadn't realized that this will only hit people who install a card
after the initial install and don't use the modular kernels, so even
though the suggested change won't hurt, it's not really a bug.
Comment 4 Jeff Johnson 1998-12-05 23:51:59 EST
I see no point in removing a valid albeit harmless error
message cosmetically. Add the device to the initrd.

Note You need to log in before you can comment on or make changes to this bug.