Bug 219010 - alsa-tools does not build on ppc
alsa-tools does not build on ppc
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: alsa-tools (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F-ExcludeArch-ppc FE-ExcludeArch-ppc64/F-ExcludeArch-ppc64
  Show dependency treegraph
 
Reported: 2006-12-09 05:05 EST by Tim Jackson
Modified: 2009-12-17 08:14 EST (History)
2 users (show)

See Also:
Fixed In Version: latest (F8,F9,devel)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-20 14:47:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Jackson 2006-12-09 05:05:04 EST
Building on ppc fails with:

/builddir/build/BUILD/alsa-tools-1.0.12/sb16_csp/cspctl.c:100: undefined
reference to `__invalid_size_argument_for_IOC'

(see jobs 22627 and 22645)

I *suspect* this might be because some (all?) of the tools don't actually make
sense on PPC, because it may be that it's physically impossible to use them on
PPC hardware. (I could be wrong here though; I know almost zero about PPC). Some
web searching hasn't immediately thrown up any answers. 

However, in any case, if you use PPC and require alsa-tools (or know more about
this problem), please comment on this bug.
Comment 1 Mamoru TASAKA 2008-03-16 09:09:20 EDT
gentoo's workaround:

http://bugs.gentoo.org/show_bug.cgi?id=86064#c2
Comment 2 David Woodhouse 2008-03-16 13:59:10 EDT
The problem is that the SNDRV_SB_CSP_IOCTL_LOAD_CODE ioctl has a size which is
too large for many architectures, including PPC. This should probably be done
differently.

Gentoo's workaround of just disabling sb16_csp on PPC seems reasonable, given
that the kernel side isn't built there either.
Comment 3 Bug Zapper 2008-05-13 22:29:42 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Tim Jackson 2008-05-19 17:57:19 EDT
Thanks for the pointer.

Fixed and in the update queue for F-8 and F-9, also built in rawhide. Feedback
welcome:

https://admin.fedoraproject.org/updates/F8/pending/alsa-tools-1.0.15-5.fc8
https://admin.fedoraproject.org/updates/F9/pending/alsa-tools-1.0.16-4.fc9
http://koji.fedoraproject.org/koji/taskinfo?taskID=618542
Comment 5 Michael Shigorin 2009-12-17 08:14:43 EST
JFYI, it seems to build on ALT Linux/ppc:
$ rpm -qlvp files/ppc/RPMS/alsa-tools-1.0.18-alt1.ppc.rpm | grep cspctl
-rwxr-xr-x    1 root    root             8208 Nov 13  2008 /usr/bin/cspctl

Not sure if it's worth bothering, maybe to clean up the messy spec a little bit.

Note You need to log in before you can comment on or make changes to this bug.