Bug 219017 - The gimp print dialog does not pick up cups printers
The gimp print dialog does not pick up cups printers
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gimp-print (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks: FC6Update
  Show dependency treegraph
 
Reported: 2006-12-09 07:22 EST by Steve
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: gimp-print-4.2.7-23.fc
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-11 11:07:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve 2006-12-09 07:22:49 EST
Description of problem:
The printers configured by cups does not appear in the gimp print dialog

Version-Release number of selected component (if applicable):
gimp-print-cups-4.2.7-22
gimp-print-4.2.7-22
gimp-print-plugin-4.2.7-22
gimp-2.2.13-1.fc6
gimp-libs-2.2.13-1.fc6
gimp-print-utils-4.2.7-22

system-config-printer-libs-0.7.41-2.fc7
system-config-printer-0.7.41-2.fc7
libgnomeprint22-2.17.0-2.fc7
gnome-python2-gnomeprint-2.17.1-2.fc7
libgnomeprintui22-2.12.1-6
desktop-printing-0.19-19.fc7


How reproducible:


Steps to Reproduce:
1. configure a printer with cups
2. start gimp
3. try to print something
  
Actual results:
i have configured and shared a network printer (ipp).
there is no problem with fc6-final, the problem only exists in fc6-rawhide(fc7).

Expected results:


Additional info:
Comment 1 Tim Waugh 2006-12-11 10:58:22 EST
I can't reproduce this.  Works fine here.

What does 'lpstat -s' say?
Comment 2 Steve 2006-12-11 11:08:11 EST
$ lpstat -s
system default destination: Canon
device for Canon: ipp://192.168.100.6:631/printers/Canon
Comment 3 Tim Waugh 2006-12-12 09:14:23 EST
What does 'locale' say?
Comment 4 Steve 2006-12-12 09:24:22 EST
# locale
LANG=de_CH.UTF-8
LC_CTYPE="de_CH.UTF-8"
LC_NUMERIC="de_CH.UTF-8"
LC_TIME="de_CH.UTF-8"
LC_COLLATE="de_CH.UTF-8"
LC_MONETARY="de_CH.UTF-8"
LC_MESSAGES="de_CH.UTF-8"
LC_PAPER="de_CH.UTF-8"
LC_NAME="de_CH.UTF-8"
LC_ADDRESS="de_CH.UTF-8"
LC_TELEPHONE="de_CH.UTF-8"
LC_MEASUREMENT="de_CH.UTF-8"
LC_IDENTIFICATION="de_CH.UTF-8"
LC_ALL=
Comment 5 Tim Waugh 2006-12-12 09:46:13 EST
Okay, I can reproduce this on FC-6 as well.

Fixed in CVS.
Comment 6 Tim Waugh 2007-01-11 07:14:40 EST
Please try 4.2.7-23.fc6 from updates-testing:

yum --enablerepo=updates-testing update 'gimp-print*'
Comment 7 Steve 2007-01-11 09:21:15 EST
sorry, i forgot, it is fixed in gimp-print-4.2.7-23.fc7.
i have/had no problem with fc6.
Comment 8 Fedora Update System 2007-01-11 10:57:16 EST
Fixed in update: gimp-print-4.2.7-23.fc6

Note You need to log in before you can comment on or make changes to this bug.