Bug 21902 - Unable to pipe into read
Summary: Unable to pipe into read
Status: CLOSED DUPLICATE of bug 19747
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: bash   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-12-07 19:30 UTC by Need Real Name
Modified: 2007-04-18 16:30 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-07 19:31:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2000-12-07 19:30:58 UTC
I am currently try to write a shell script that will pipe the output into 
the read statement.  It is not working at all.  Example is
"snmpget 172.1.1.1 public interfaces.ifNumber.0 | awk '{print $3}' | read 
NUM"
It is not piping the output, which is a number, into the variable.

Comment 1 Karsten Hopp 2000-12-12 16:47:27 UTC
please have a look at Bugzilla #19747

*** This bug has been marked as a duplicate of 19747 ***


Note You need to log in before you can comment on or make changes to this bug.