Bug 219024 - kde sound server crashes when konsole beeps.
kde sound server crashes when konsole beeps.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kdebase (Show other bugs)
4.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-09 08:56 EST by Reza Bakhshi
Modified: 2009-04-14 17:12 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-14 17:12:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Reza Bakhshi 2006-12-09 08:56:28 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

Description of problem:
sound server crashes when kde applications are going to produce any sound.
you simple log in using KDE desktop, you open konsole and write something and press <tab> to complete command and suddenly kde crash handler comes up and informs you about sound server crash.
some times it happens two or more times and other times it may not happen, sorry i know that it's very unusual and un-informic but it's all i can get

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes


Steps to Reproduce:
1. open kde
2. open konsle
3. type "l" and then press <tab> to complete the command

Actual Results:
kde crash handle came up to handle sound server crash

Expected Results:
just beeping in konsole. and showing me a list of available commands like <ls>

Additional info:
Using host libthread_db library "/lib/tls/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1208113472 (LWP 23740)]
[KCrash handler]
#4  0x07952d97 in QMap<KIO::ListJob*, KDirLister::KDirListerPrivate::JobData>::insert () from /usr/lib/libkio.so.4
#5  0x0794b4fe in KDirLister::jobStarted () from /usr/lib/libkio.so.4
#6  0x0794f068 in KDirListerCache::updateDirectory ()
   from /usr/lib/libkio.so.4
#7  0x07950350 in KDirListerCache::FilesAdded () from /usr/lib/libkio.so.4
#8  0x078edcf6 in KDirNotify::process () from /usr/lib/libkio.so.4
#9  0x006143f0 in DCOPClient::receive () from /usr/lib/libDCOP.so.4
#10 0x00618bfe in DCOPClient::send () from /usr/lib/libDCOP.so.4
#11 0x006192d8 in DCOPClient::send () from /usr/lib/libDCOP.so.4
#12 0x0062043f in KDE_IceProcessMessages () from /usr/lib/libDCOP.so.4
#13 0x0060f5df in DCOPClient::processSocketData () from /usr/lib/libDCOP.so.4
#14 0x006199c0 in DCOPClient::qt_invoke () from /usr/lib/libDCOP.so.4
#15 0x06f2f450 in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#16 0x06f2f9e2 in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#17 0x07261190 in QSocketNotifier::activated ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#18 0x06f4a4d5 in QSocketNotifier::event ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#19 0x06ed08f9 in QApplication::internalNotify ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#20 0x06ed0a8a in QApplication::notify ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#21 0x004853b8 in KApplication::notify () from /usr/lib/libkdecore.so.4
#22 0x06ec4db4 in QEventLoop::activateSocketNotifiers ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#23 0x06e80bde in QEventLoop::processEvents ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#24 0x06ee5f25 in QEventLoop::enterLoop ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#25 0x06ee5e7e in QEventLoop::exec () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#26 0x06ecfafb in QApplication::exec () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#27 0x006d38dc in kdemain () from /usr/lib/libkdeinit_konqueror.so
#28 0x0011f694 in kdeinitmain () from /usr/lib/kde3/konqueror.so
#29 0x0804dfb1 in ?? ()
#30 0x00000004 in ?? ()
#31 0x0944f1f0 in ?? ()
#32 0x00000001 in ?? ()
#33 0x00000001 in ?? ()
#34 0x00000001 in ?? ()
#35 0x00000000 in ?? ()
Comment 1 Martin Stransky 2006-12-10 16:50:00 EST
It doesn't look like an alsa bug...
Comment 2 Ngo Than 2009-04-14 17:12:07 EDT
it looks like a crash in konqueror. I didn't see the crash with current RHEL-4-U7

Note You need to log in before you can comment on or make changes to this bug.