Bug 219046 - Always asks to 'Specify Printer Driver'
Always asks to 'Specify Printer Driver'
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: desktop-printing (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
:
Depends On:
Blocks: FC6Update
  Show dependency treegraph
 
Reported: 2006-12-09 19:23 EST by vfiend
Modified: 2013-03-05 22:48 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-21 15:30:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description vfiend 2006-12-09 19:23:12 EST
Description of problem: Even though the printer is configured in
system-config-printer and it has been told what the correct printer driver is,
it asks every time the printer is turned on.


Version-Release number of selected component (if applicable):
system-config-printer-0.7.40-1.fc6



How reproducible: Every time printer is turned on


Steps to Reproduce:
1. Turn on printer
2. Asks to specify correct printer driver
3. Tell it the printer driver
4. Turn off the printer
5. Turn the printer on again
  
Actual results: Asks to specify the correct printer driver again


Expected results: Should remember the specified printer driver and not ask again


Additional info: Printer is a Canon i550 connected via usb and uses the Canon
BJC-7100 driver.
Comment 1 Tim Waugh 2006-12-11 13:05:43 EST
1. What does '/usr/sbin/lpinfo -l -v' say?
2. Also what does 'lpstat -s' say?
Comment 2 vfiend 2006-12-11 15:23:22 EST
[chris@icarus ~]$ /usr/sbin/lpinfo -l -v
Device: uri = socket
        class = network
        info = AppSocket/HP JetDirect
        make-and-model = Unknown
        device-id = 
Device: uri = beh
        class = network
        info = Backend Error Handler
        make-and-model = Unknown
        device-id = 
Device: uri =
hal:///org/freedesktop/Hal/devices/usb_device_4a9_1073_20CIDY_if0_printer_noserial
        class = direct
        info = Canon i550
        make-and-model = Canon i550
        device-id = MFG:Canon;MDL:i550;CLS:PRINTER;
Device: uri = usb://Canon/i550
        class = direct
        info = Canon i550 USB #1
        make-and-model = Canon i550
        device-id =
MFG:Canon;CMD:BJL,BJRaster3,BSCC,TXT01;MDL:i550;CLS:PRINTER;DES:Canon
i550;VER:1.01;STA:10;
Device: uri = hp:/no_device_found
        class = direct
        info = hp no_device_found
        make-and-model = Unknown
        device-id = 
Device: uri = http
        class = network
        info = Internet Printing Protocol (http)
        make-and-model = Unknown
        device-id = 
Device: uri = ipp
        class = network
        info = Internet Printing Protocol (ipp)
        make-and-model = Unknown
        device-id = 
Device: uri = lpd
        class = network
        info = LPD/LPR Host or Printer
        make-and-model = Unknown
        device-id = 
Device: uri = parallel:/dev/lp0
        class = direct
        info = LPT #1
        make-and-model = Unknown
        device-id = 
Device: uri = scsi
        class = direct
        info = SCSI Printer
        make-and-model = Unknown
        device-id = 
Device: uri = serial:/dev/ttyS0?baud=115200
        class = serial
        info = Serial Port #1
        make-and-model = Unknown
        device-id = 
Device: uri = smb
        class = network
        info = Windows Printer via SAMBA
        make-and-model = Unknown
        device-id = 
[chris@icarus ~]$ lpstat -s
system default destination: Canoni550
device for Canoni550: usb://Canon/i550



I believe it originally had a hal://.... device, I changed it to a usb://...
device using system-config-printer, same issue both ways
Comment 3 Tim Waugh 2006-12-11 16:42:35 EST
Can you try keeping it 'hal://...' just so we can make sure it really does still
happen then?  It doesn't currently know how to compare the hal names with the
usb names, so that would explain it.

I'd just like to be sure about what the scope of the problem is.  Thanks.
Comment 4 vfiend 2006-12-11 17:58:36 EST
Sure, I deleted it in system-config-printer and then readded it using the
default hal://... device. Same issue, and here's the new output.

[chris@icarus ~]$ /usr/sbin/lpinfo -l -v
Device: uri = socket
        class = network
        info = AppSocket/HP JetDirect
        make-and-model = Unknown
        device-id = 
Device: uri = beh
        class = network
        info = Backend Error Handler
        make-and-model = Unknown
        device-id = 
Device: uri =
hal:///org/freedesktop/Hal/devices/usb_device_4a9_1073_20CIDY_if0_printer_noserial
        class = direct
        info = Canon i550
        make-and-model = Canon i550
        device-id = MFG:Canon;MDL:i550;CLS:PRINTER;
Device: uri = usb://Canon/i550
        class = direct
        info = Canon i550 USB #1
        make-and-model = Canon i550
        device-id =
MFG:Canon;CMD:BJL,BJRaster3,BSCC,TXT01;MDL:i550;CLS:PRINTER;DES:Canon
i550;VER:1.01;STA:10;
Device: uri = hp:/no_device_found
        class = direct
        info = hp no_device_found
        make-and-model = Unknown
        device-id = 
Device: uri = http
        class = network
        info = Internet Printing Protocol (http)
        make-and-model = Unknown
        device-id = 
Device: uri = ipp
        class = network
        info = Internet Printing Protocol (ipp)
        make-and-model = Unknown
        device-id = 
Device: uri = lpd
        class = network
        info = LPD/LPR Host or Printer
        make-and-model = Unknown
        device-id = 
Device: uri = parallel:/dev/lp0
        class = direct
        info = LPT #1
        make-and-model = Unknown
        device-id = 
Device: uri = scsi
        class = direct
        info = SCSI Printer
        make-and-model = Unknown
        device-id = 
Device: uri = serial:/dev/ttyS0?baud=115200
        class = serial
        info = Serial Port #1
        make-and-model = Unknown
        device-id = 
Device: uri = smb
        class = network
        info = Windows Printer via SAMBA
        make-and-model = Unknown
        device-id = 
[chris@icarus ~]$ lpstat -s
system default destination: Canoni550
device for Canoni550:
hal:///org/freedesktop/Hal/devices/usb_device_4a9_1073_20CIDY_if0_printer_noserial
Comment 5 Tim Waugh 2006-12-12 08:52:25 EST
So it sounds like it isn't actually adding the queue.
Comment 6 vfiend 2007-01-21 15:30:10 EST
It seems to be working properly now, I just updated desktop-printing to the
latest FC6 updates a few days ago and that seems to have fixed it.

Note You need to log in before you can comment on or make changes to this bug.