Bug 219059 - RFE: iPod support
RFE: iPod support
Product: Fedora
Classification: Fedora
Component: quodlibet (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeffrey C. Ollie
Fedora Extras Quality Assurance
Depends On: python-gpod-review 219289
  Show dependency treegraph
Reported: 2006-12-10 01:14 EST by Michel Alexandre Salim
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-07-12 11:30:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Michel Alexandre Salim 2006-12-10 01:14:19 EST
Description of problem:
quodlibet's iPod support depends on the Python bindings for libgpod. This is now
available in Extras development as python-gpod (bz #217066). Could quodlibet be
rebuilt with a BR on this once it lands in FE5/6 as well?

Version-Release number of selected component (if applicable):
Additional info:
As a side note, the following plugins are currently broken:
brainz (depends on the old musicbrainz)
cddb (needs CDDB from cddb-py.sf.net, not available in Extras yet)
lastfmsubmit (needs lastfm python module)
shell.2 (.py file is actually an HTTP 404 file)

These should probably be disabled, or the dependencies included (there might be
a version of brainz that depends on either python-tunepimp or python-musicbrainz2)
Comment 1 Jeffrey C. Ollie 2006-12-12 00:34:43 EST
I've pushed a build for development that requires python-gpod.  When is
python-gpod going to be built for FC5 & FC6?  I see that it isn't even branched
in CVS yet.
Comment 2 Todd Zullinger 2007-01-21 18:36:20 EST
python-gpod is now built for FC6 and as soon as libgpod-0.4.2 moves from testing
it should be generally available.  You can check it right now if you enable
updates-testing and then update libgpod.

I don't think that libgpod-0.4.2 is going to get pushed for FC5.  It'd be nice
if it did, but I don't know that AlexL (libgpod maintainer) has enough free time
to test out that update.  If anyone wants to push for that or help out, I'd be
happy to do anything I could to get it into FC5 and then build python-gpod there.
Comment 3 Jeffrey C. Ollie 2007-07-12 11:30:33 EDT
Now that FC5 is closed for new builds, I'm going to close this bug.

Note You need to log in before you can comment on or make changes to this bug.