Bug 219062 - Clicking OK in edit material dialog does not close the dialog.
Summary: Clicking OK in edit material dialog does not close the dialog.
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: wings   
(Show other bugs)
Version: 6
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Gérard Milmeister
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-12-10 08:38 UTC by Joni Yrjana
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-10 11:15:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joni Yrjana 2006-12-10 08:38:54 UTC
Description of problem:
When clicking OK button on material edit window, a dialog saying
"wpc_pov:dialog/2: crashed" is displayed, the material edit window is not closed
and changes are not saved.

Version-Release number of selected component (if applicable):
wings-0:0.98.32b-9.fc6.i386

How reproducible:
Everytime.

Steps to Reproduce:
1. Start Wings.
2. Open the outliner window (from menu Window->Outliner).
3. Choose material "default", right click on it and choose edit.
4. Click OK.
  
Actual results:
The material edit window does not close and an error message is displayed.

Expected results:
The material edit window should close and the changes to the material should be
saved.

Additional info:
When run from commandline, the output looks like this:
$ rm -rf $HOME/.wings ; wings
Trying OpenGL modes
  [{buffer_size,32},{depth_size,32},{stencil_size,8},{accum_size,16}]
  [{buffer_size,24},{depth_size,32},{stencil_size,8},{accum_size,16}]
  [{buffer_size,24},{depth_size,24},{stencil_size,8},{accum_size,16}]
Actual: RGBA: 8 8 8 0 Depth: 24 Stencil: 8 Accum: 16 16 16 16
wpc_pov:dialog/2: crashed: {error,[{kayos_utils,
                                       split_list,
                                       [[{material_editor_ok,true}],45]},
                                   {pov_ui,material_result,3},
                                   {wings_plugin,dialog_result1,3},
                                   {wings_material,plugin_results,3},
                                   {wings_material,'-edit_dialog/4-fun-1-',6},
                                   {wings_ask,return_result,1},
                                   {wings_wm,handle_event,3},
                                   {wings_wm,send_event,2}]}

Comment 1 Joni Yrjana 2006-12-10 08:55:37 UTC
When downloaded and installed binary package of Wings 0.98.36 from
www.wings3d.com, the above error does not happen.


Comment 2 Gérard Milmeister 2006-12-10 10:37:27 UTC
It seems that this happens when povray is not available. I will have to remove
the povray plugin then.

Comment 3 Gérard Milmeister 2006-12-10 11:15:43 UTC
I separated the povray plug-in from the main package. Only install the
wings-povray package if povray is actually installed.


Note You need to log in before you can comment on or make changes to this bug.