Bug 219063 - Runlevel 5 boot fails; startx generates error
Runlevel 5 boot fails; startx generates error
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
6
i686 Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-10 04:20 EST by Sam
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-09 03:13:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sam 2006-12-10 04:20:00 EST
Description of problem:
I cannot start xwindows. I performed a default install in FC 6 and when booting,
I get the command prompt. I ran "runlevel" with the result "N 5" (so I am in
runlevel 5). When I try running "startx", it gives me the error:

Fatal server error:
Server is already active for display 0

Xlib: connection to ":0.0" refused by server
Xlib: Invalid MIT-MAGIC-COOKIE-1 key
giving up.
xinit: unable to connect to X server
xinit: No such process (errno 3): Server error.


I follow the onscreen instructions to delete a file in /tmp/.X0-lock, but I
still get the error.

Version-Release number of selected component (if applicable): Default install
for FC6 (2.6.18-1.2798.fc6)


How reproducible: Always 


Steps to Reproduce:
1. Boot FC6 on HP Pavilion dv9000z
2. Log in at command prompt as root or as local (errors occur either way)
3. Type in "runlevel" to observe you are at runlevel 5
4. Type in "
  
Actual results:
Not in XWindows in runlevel 5; also, cannot start XWindows manually

Expected results: Boot in XWindows


Additional info: Graphical install was executed seemingly flawlessly.
Comment 1 Sam 2006-12-10 07:08:51 EST
Oops! Under Steps to Reproduce, Step 4 is to type in "startx". Regardless, in an
ideal world steps 3 and 4 should not even be necessary since I am in Runlevel 5.

Also, the system is dual boot. 10 GB for Linux, the rest for Windows XP. (Once I
get Linux working I am probably going to change that, but I need to get it
working first!) Now that I have booted in Windows, I can provide some details
about the hardware:

HP Pavilion Entertainment PC (dv9000z). It is a custom build selected from a
small subset of options. Specs include:

1.8 GHz (32-bit) Mobile AMD Sempron(tm) 3500+ processor
Display: nVidia GeForce Go 6150
Sound: Conexion High Definition Audio (I did hear sound in the test during install)
1 GB RAM
Comment 2 Matěj Cepl 2006-12-27 15:42:57 EST
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 3 Sam 2007-01-08 19:05:55 EST
The weirdest thing....  Now when I boot, it works fine! I will let you know if
it happens again.
Comment 4 Matěj Cepl 2007-01-09 03:13:43 EST
Wonderful! if there are any more problems, please, reopen this bug.

Note You need to log in before you can comment on or make changes to this bug.