Bug 219064 - MULTIPLE bugs in getting "printer and file sharing" working
MULTIPLE bugs in getting "printer and file sharing" working
Status: CLOSED DUPLICATE of bug 216802
Product: Fedora
Classification: Fedora
Component: freenx (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Axel Thimm
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-10 04:29 EST by Need Real Name
Modified: 2007-12-31 05:40 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-31 05:40:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fixed versions of nxnode, nxclient, nxprint (13.52 KB, application/x-compressed)
2006-12-10 04:29 EST, Need Real Name
no flags Details
Updated versions of nxp (13.54 KB, application/x-compressed)
2006-12-12 13:43 EST, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2006-12-10 04:29:59 EST
Description of problem:
Neither printer nor file sharing work as configured.
The existing nxnode and nxclient scripts have multiple bugs in them.

By hacking around I was able to get printer sharing working (and even added some
new functionality that filled previous holes).

I was not able to get file sharing working seamlessly since Fedora Core now uses
mount.cifs (which uses port 445 [SMB]) rather than smbmount (which uses port 139
[NBSS]). Therefore, while I could relatively easily fix the scripts, you still
would need to manually do the port forwarding from the client side since I don't
have the source for the Windows NX client. I will, however, show how to do it
manually below.

--------------------------------------------
Bugs, fixes, and improvements for printer sharing: (working, corrected versions
are attached below:

NXNODE:
- BUG: Old cupsd processes tied to old sessions were left running which was not
only messy but also blocked the port forwarding, preventing new sessions from
establishing properly
  SOLUTION: Added code in node_terminate_session to also kill the cupsd process
associated with the terminated session

- BUG: Stripped down cupsd.conf means that the system default policy is used
which requires authentication to add/drop printers or even set a default
printer. Also, several of the directories were not referenced properly or created.

- SOLUTION: Rewrote the cupsd.conf based on /etc/cups/cupsd.conf and its default
security policy.
   ** $USER added to SystemGroup
   ** Proper paths given for Access, Error, and Page logs
   ** CacheDir and StateDir added (and .nx/C-$sess_id/cups/cache directory created)
   ** Switched to single 'Listen' directive rather than separate 'Port' and
'Server Name' directives
   ** Access restrictions added from /etc/cups/cupsd.conf
   ** Default policy from /etc/cups/cupsd.conf modified to allow Add, Delete,
and Default printer without (password) authentication

- BUG: pstoraster.convs needs to be in .nx/C-$sess_id/cups/
  SOLUTION: Fixed

- BUG: Device URI for smb can't use localhost but instead needs to reference
127.0.0.1 for proper netbios name resolution.
  SOLUTION: Fixed

- ENHANCEMENT: Added 'guest' to allowed users so that you can print test pages
from the CUPS web interface

- BUG: IPP_PORT environment variable no longer used for storing server name
  SOLUTION: Substituted '-h localhost:$IPP_PORT' format

NXCLIENT:
- BUGS: 'break' in the parsing option line for '--printer' means that the
'display' variable may not get parsed (and indeed doesn't)
  SOLUTION: Removed 'break'

- BUGS: xdialog not part of Fedora Core 6 (or any of the major repos) and
xmessage buttons don't work if you have more than a few printer ppd choices 
- SOLUTION: Added support for 'dialog' (which is part of Fedora core) launched
in an xterm.

- ENHANCEMENT: In the original implementation, utility_printer re-parses all the
ppd files every time it looks up a vendor or a model. This becomes exceedingly
slow when there are a large number of vendors and ppd files (as when using
foomatic drivers). Instead, changed functionality to only parse through ppd
files once and cache the vendor and model lists in ~/.nx/config/drivers.cache.all

NXPRINT:
- ENHANCEMENT: Original implementation only queried the 3 (non-zipped) ppd files
in /usr/share/cups/model. Added support for gzipped drivers and for parsing the
1500+ foomatic drivers.

- BUG: 'nxprint --printers' prints out the system cupsd queue rather than the
local cupsd queue
  SOLUTION: Fixed by adding "-h localhost:port" code


---------------------------------
MOUNTING remote smb shares over (nx)ssh...
1. As mentioned above, mount.cifs uses port 445 rather than port 139. So, first
add remote port forwarding from the client machine, e.g.,

   ssh <remoteserver> -R 12001:localhost:445

2. On the remote server run: (as superuser)

   mount.cifs //127.0.0.1/<client share> /mnt/<mount name> -o
username=<usrname>,ip=127.0.0.1,port=12001

..then enter password when prompted
Comment 1 Need Real Name 2006-12-10 04:30:00 EST
Created attachment 143238 [details]
Fixed versions of nxnode, nxclient, nxprint
Comment 2 Need Real Name 2006-12-12 13:43:43 EST
Created attachment 143426 [details]
Updated versions of nxp
Comment 3 Need Real Name 2007-04-27 10:12:19 EDT
I noticed that the bug was reassigned.
Has anyone reviewed my patches? These patches allow both sharing of printers and
filesystems.
Comment 4 Axel Thimm 2007-04-27 11:19:24 EDT
Not yet, but that will happen soon. First I will freshen up the packages to the
latest & add x86_64 support. This is already known to work fine and is just a
matter of importing into Fedora.

After having that basis, I will check what reports are still valid (this will be
one for sure) and review them.
Comment 5 Axel Thimm 2007-05-19 10:24:01 EDT
This is a collective bugzilla comment for nx/freenx bugs.

New versions of nx and freenx have entered the repos. Please check if the bug
report is still valid with the new versions (freenx-0.6.0-12 and nx-2.1.0-19).
Comment 6 Axel Thimm 2007-12-28 18:37:40 EST
This is a collective bugzilla comment for nx/freenx bugs.

Some time ago these bugs were probably dealt with by new versions as mentioned
in the previous comment. If these updates fixed the bug, please close as fixed,
otherwise please comment on the open issues. Thanks!

(if no comments are made for another week I will assume that the bug is "fixed")
Comment 7 Axel Thimm 2007-12-31 05:40:30 EST

*** This bug has been marked as a duplicate of 216802 ***

Note You need to log in before you can comment on or make changes to this bug.