Bug 219067 - fwbackups: A few interface nitpicks
fwbackups: A few interface nitpicks
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: fwbackups (Show other bugs)
6
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Stewart Adam
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-10 05:07 EST by Bernard Johnson
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-25 16:00:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bernard Johnson 2006-12-10 05:07:28 EST
Description of problem:
There are a few inconsistencies in the user interface that should be addressed:

1)  Main welcome screen "Welcome to fwbackups.  Click the Administration tab to
configure backups, or if you wish to start a backup, click the Backup tab". 
There is neither a "Administration" tab or a "Backup" tab.

2) Automated Backups: "Click Add to add more paths to the list..." Are these
targets or destinations?  It's unclear.

3) Add path dialog:  Needs directory browser.

4) Adding paths:  The same path can be added multiple times.

5) Automated Backups:  I've added a path.  Now what?  No clear direction.

6) Interface does not use a busy cursor when it's busy.

Saw this pop up in the terminal window too:
Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/fwbackups/Callbacks.py", line 445, in
ab_remove
    model.remove( iterator )
TypeError: iter should be a GtkTreeIter

Version-Release number of selected component (if applicable):
fwbackups-1.42.1-2.fc6
Comment 1 Stewart Adam 2006-12-10 11:46:04 EST
(1) I originally had a 'Administration' tag, but changed the name and forgot to
change the label... In v1.43 I'm re-doing all the names and interface anyways
and so this won't be a problem.

(2) I'm going to implement Backup Sets now, so you can have eg the "Documents"
set to run at one time, while "Music" will be run at another. Each set can have
their own paths with them, so it's very useful.

(3) Will-do - I was having some trouble with how it selects directories, but I
got that sorted out.

(4) I never thought of that one - I'll add some path-checks to the code

(5) It automatically saves them, and the time to run it at is in 'Preferences' -
But this will be united into one dialog when using sets in v1.43.

(6) It's because I didn't put checks to see if the user's actually highlighted a
path when hitting 'remove' - v1.43 does use checks.
Comment 2 Bernard Johnson 2006-12-10 16:30:15 EST
Please consider also making the application usable by normal users.  As you may
or may not know, pybackpack, bug #168690, (a python application for backing up
user files) has had some serious setbacks and may not make it into FE.
Comment 3 Stewart Adam 2006-12-11 08:05:15 EST
This is being done too - Once a user crontab is created, then the program can
run in user or root mode.

Note You need to log in before you can comment on or make changes to this bug.