Bug 219105 - saving image crashes Gimp
saving image crashes Gimp
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gimp (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nils Philippsen
David Lawrence
: Regression, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-10 17:34 EST by Josef Kubin
Modified: 2013-04-12 14:55 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-26 04:25:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
testing image (12.44 KB, image/png)
2007-03-10 21:06 EST, Josef Kubin
no flags Details
output from terminal (6.31 KB, text/plain)
2007-03-10 21:07 EST, Josef Kubin
no flags Details

  None (edit)
Description Josef Kubin 2006-12-10 17:34:02 EST
Description of problem:
Long work with Gimp sometimes means lost of unsaved work, because clicking on
menu item "Save as..." or "Save a Copy..." means crash. I can't exactly say,
what function during work is the culprit of instability, but it should be
probably ordinary tool, because I'm using basic set of tools.

Version-Release number of selected component (if applicable):
gimp-2.2.13-1.fc6

How reproducible:
ocassionally

Steps to Reproduce:
1.some time work over an image - work with layers, 
2.{Save as ..., Save a Copy ...} is the last item what I have clicked
3.then immediately crash

Additional info:
During long work I can see rectangular moving artefact on all screens - size cca
 width:100px;height:100px.
Comment 1 Nils Philippsen 2006-12-12 10:04:11 EST
Are there any messages pertaining to this issue on stderr/stdout? Please run
gimp from the terminal -- "ulimit -c unlimited" and "gimp --stack-trace-mode
query" to dump a core when it crashes -- and attach them here (if there are any)
as well as  possible core dumps.
Comment 2 Ben Levenson 2006-12-13 08:53:09 EST
This should be fixed in RHEL-5
Comment 3 Josef Kubin 2006-12-15 06:37:32 EST
Hold on, I have to find a time to play with gimp ... Perhaps next week.
Comment 4 Pete Graner 2006-12-15 06:41:34 EST
This is blocking the release, we need the info the developer asked for ASAP.
CC:ing in PM for more visibility. Putting back in NEEDINFO.
Comment 5 Josef Kubin 2006-12-22 14:32:24 EST
It is hard to reproduce, I have tested it several days without crash.
I'll watch out on this application, because I'm also a web developer and
sometimes need to create some pictures.
I'm using dual-head configuration which isn't so common thing.
The moving squarish artefact sometimes appears especially when I'm working with
text and layers.
Comment 6 Pete Graner 2006-12-23 21:44:32 EST
Closing as WORKS4ME, pls reopen if your able to reproduce. Thanks!
Comment 7 Josef Kubin 2007-03-10 21:04:34 EST
I'am able to reproduce it with high probability !

devilishy simple:

1) Start Gimp - `gimp --stack-trace-mode query`
2) Open image tux.png
3) Save image tux2.png
4) playing with 
5) delete saved image (tux2.png) from HDD
6) in a while it crashes (hard to say when)

tested image and output from terminal will be appended
Comment 8 Josef Kubin 2007-03-10 21:06:24 EST
Created attachment 149785 [details]
testing image
Comment 9 Josef Kubin 2007-03-10 21:07:44 EST
Created attachment 149786 [details]
output from terminal
Comment 11 Nils Philippsen 2007-04-20 04:20:01 EDT
[changing product to RHEL final]

Josef, what are the versions of gimp, gnome-vfs2, gtk2, glib2 and glibc on your
system? I'm asking because I couldn't reproduce it here on my machine which is
an updated FC-6 which has the same gimp package as RHEL5 as it hasn't been built
anew since the split. Does your machine happen to be x86_64 as well?
Comment 15 Josef Kubin 2007-07-09 08:49:45 EDT
I can't reproduce it ...
Comment 16 Nils Philippsen 2007-07-26 04:25:58 EDT
In that case I can't fix it ;-). I'd seriously like to re-base the gimp in
RHEL4/5 as there are a huge number of bugfixes in the current upstream versions.
But I don't think I have the PM/QA buy-in for that.

Note You need to log in before you can comment on or make changes to this bug.