This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 21911 - xinetd/ SWAT: can't get localhost:ANYPORTNUMBER
xinetd/ SWAT: can't get localhost:ANYPORTNUMBER
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: xinetd (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-07 17:09 EST by Tim Z Falconer
Modified: 2007-04-18 12:30 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-08 14:57:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
log of: 1:up2date first try crash 2: ps ax 3: up2date successful installs (7.52 KB, text/plain)
2000-12-07 22:11 EST, Tim Z Falconer
no flags Details

  None (edit)
Description Tim Z Falconer 2000-12-07 17:09:14 EST
Trying to run SWAT under Netscape 4.75 or Lynx. All following browser tests
were performed with both netstape and lynx. I have a web proxy (webwasher)
running on another machine, I've tried netscape with and without proxy
enabled. I have a Linksys BEFSR41 DSL router/firewall, but I don't believe
that it's involved. 

I am able to access

http://localhost

and

http://127.0.0.1

but I cannot access

http://localhost:901

nor 

http://127.0.0.1:901

There is a description of the problem in:

http://www.redhat.com/support/docs/gotchas/7.0/gotchas-7-6.html

This solution (listed below) doesn't work for me: 
change /etc/xinetd.d/swat file: 

               only_from = localhost 
               
to 
               only_from = 127.0.0.1
               
The supposed bugfix is here:

http://www.redhat.com/support/errata/RHBA-2000-090-02.html

which says to upgrade xinetd:

ftp://updates.redhat.com/7.0/i386/xinetd-2.1.8.9pre11-1.i386.rpm

I downloaded, installed, checked installation, rebooted (because I was
unsure which services might be affected, so best to restart them all),
retested, rechecked installation (using GnoRPM FIND) and retested. 

It still doesn't work. 

Am I missing something obvious? I haven't even found a workaround that
works (besides manual smb config file editing and install).
Comment 1 Trond Eivind Glomsrxd 2000-12-07 17:12:06 EST
It is confirmed to work with an updated system (run up2date). Are you sure you
actually have the service enabled?
Comment 2 Tim Z Falconer 2000-12-07 22:11:53 EST
Created attachment 6190 [details]
log of: 1:up2date first try crash 2: ps ax 3: up2date successful installs
Comment 3 Tim Z Falconer 2000-12-07 22:12:44 EST
SWAT <is> listed in /etc/services, if that's what you mean.  Please let me know
if I'm missing something. 
I tried up2date, with mixed results; since I did an "everything" install,
up2date gives me a huge (300MB) list of updates. First time through, I selected
MANY of them, but it crashed (see attached file). 
The second & third times I ran up2date, I was more conservative, looking for
packages that <could> be related to my problem. I updated glibc and apache and a
couple of other things, and rebooted again, but no luck.; still the same
problems where localhost:901 gets me nothing and 127.0.0.1:901 gets me a
"connection refused" message...hmmm, did I mention that before? 
Now that xinetd has been updated, should I set the /etc/xinetd/swat file back to
localhost? I'll try that in the meantime. 
thx, tzf
Comment 4 Trond Eivind Glomsrxd 2000-12-08 14:57:05 EST
No, I want to know if the service is enabled... what does /etc/xinetd.d/swat
look like?
Comment 5 Tim Z Falconer 2000-12-08 22:47:55 EST
Yep, that was it! 
Thanks for pointing me in the right direction :) ! 
Sorry for the bother :(
tzf
Comment 6 whitecloud 2001-06-05 02:44:07 EDT
I'm trying to get swat running on my station and followed this case resolution 
thinking it would help, but it still won't work.

I checked /etc/services which seems ok. I checked /etc/hosts and it is as 
recommended in bug resolution 17839. In /etc/xinetd.d/swat, I set disable = no 
as mentioned above and tested with setting only_from = myip, only_from = 
127.0.0.1, and even with removing this line from the file but I always get the 
same result.

When I run up2date, which packages should I update to help swat running??

Talking about services, I set both swat and linuxconf-web to start in ntsysv 
but I still get the error message "connection reset by peer" when connecting to 
localhost:901. Do I understand from the above resolution that I should try 
http://127.0.0.1:901???

If what you mean by starting the service is setting the line disable = no 
in /etc/xinetd.d/swat, then that still doesn't solve it for me.

Is this whole issue solved in RH 7.1??


Note You need to log in before you can comment on or make changes to this bug.