Bug 21913 - sort is broken
Summary: sort is broken
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: textutils   
(Show other bugs)
Version: 6.2
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 58233 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-12-07 23:16 UTC by Geoffrey Peck
Modified: 2007-04-18 16:30 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-07 23:22:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
example of incorrect sorting behavior (651 bytes, text/plain)
2000-12-07 23:22 UTC, Geoffrey Peck
no flags Details

Description Geoffrey Peck 2000-12-07 23:16:27 UTC
Changing sort so that it no longer functions on simple text files as it 
has for 25+ years is a terrible idea. (Yes, I've been using sort on Unix 
for that long.)

If you want an i18n sort (and yes, I've read the other bug reports, so I 
know the "LC_ALL="C" workaround), that's fine. But the DEFAULT behavior, 
when the user does nothing special, should be the same as it has been 
since the beginning of (Unix) time.

This change has broken many scripts, and is causing problems which people 
probably aren't even fully aware of.

Comment 1 Geoffrey Peck 2000-12-07 23:22:20 UTC
Created attachment 6170 [details]
example of incorrect sorting behavior

Comment 2 Bernhard Rosenkraenzer 2000-12-12 16:55:05 UTC
POSIX demands this default behavior.
Get used to it or export LC_ALL=C in your startup files.

Comment 3 Radek Liboska 2002-01-12 07:54:31 UTC
*** Bug 58233 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.