Bug 219134 - Synaptic crashes upon start
Synaptic crashes upon start
Status: CLOSED DUPLICATE of bug 211254
Product: Fedora
Classification: Fedora
Component: synaptic (Show other bugs)
6
i386 Linux
medium Severity urgent
: ---
: ---
Assigned To: Axel Thimm
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-11 07:52 EST by Imtiaz Rahi
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-11 15:50:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
GDB backtrace of Synaptic after it crashes (1002 bytes, text/plain)
2006-12-11 07:52 EST, Imtiaz Rahi
no flags Details

  None (edit)
Description Imtiaz Rahi 2006-12-11 07:52:21 EST
Description of problem:
Synaptic crashes when started. Previously it was working but after I have
updated few packages it does not work now.
even installed updated syanaptic package from extras, but no joy.

Version-Release number of selected component (if applicable): 0.57.2-5.2


How reproducible:
Just start synaptic from console or from menu entry.

Steps to Reproduce:
1. Start synaptic from menu entry.
2. Provide root password in password box.
3.
  
Actual results:
When run from console by typing 'synaptic'. After providing root password,
window shows up and immediately crashes. On console I found this line showing up
every time.

(synaptic:9609): Gtk-CRITICAL **: gtk_widget_hide: assertion `GTK_IS_WIDGET
(widget)' failed

The number beside "(synaptic:" is different sometimes.

Expected results:


Additional info:
Also, attaching the gdb backtrace in a text file.
Comment 1 Imtiaz Rahi 2006-12-11 07:52:22 EST
Created attachment 143287 [details]
GDB backtrace of Synaptic after it crashes
Comment 2 Axel Thimm 2006-12-11 10:40:04 EST
Can you try using apt instead of synaptic? The backtrace looks very much like it
is libapt related and if apt fails in a similar manner, then you may be seeing a
duplicate of bug #211254
Comment 3 Imtiaz Rahi 2006-12-11 13:02:39 EST
Hi Axel,
You are right. I ran 'apt-get update' and it segfaulted.
I was using "apt-0.5.15lorg3.2-8.fc6".
Then I went back to "apt-0.5.15lorg3.2-7.fc6" and apt segfaulted.
Its very strange, this version of apt was working ok previously.

Here is the backtrace:
====================================
(gdb) run update
Starting program: /usr/bin/apt-get update
...............................................
...............................................
Failed to fetch
http://download.fedora.redhat.com/pub/fedora/linux/extras/6/i386/repodata/filelists.xml
 MD5Sum mismatch
Failed to fetch
http://download.fedora.redhat.com/pub/fedora/linux/core/updates/6/i386/repodata/primary.xml
 MD5Sum mismatch
Failed to fetch
http://download.fedora.redhat.com/pub/fedora/linux/core/updates/6/i386/repodata/filelists.xml
 MD5Sum mismatch
Reading Package Lists... 0%
Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1208695072 (LWP 14209)]
0x009712d3 in strlen () from /lib/libc.so.6
(gdb) backtrace 
#0  0x009712d3 in strlen () from /lib/libc.so.6
#1  0x001a18b6 in std::string::compare () from /usr/lib/libstdc++.so.6
#2  0x00c526f1 in rpmRepomdIndex::FindInCache () from
/usr/lib/libapt-pkg-libc6.4-6.so.2
#3  0x00cbe150 in pkgCacheGenerator::ListParser::NewProvides () from
/usr/lib/libapt-pkg-libc6.4-6.so.2
#4  0x00cbf599 in pkgMakeStatusCache () from /usr/lib/libapt-pkg-libc6.4-6.so.2
#5  0x00ca8451 in pkgCacheFile::BuildCaches () from
/usr/lib/libapt-pkg-libc6.4-6.so.2
#6  0x00ca8574 in pkgCacheFile::Open () from /usr/lib/libapt-pkg-libc6.4-6.so.2
#7  0x08064c9a in std::vector<pkgSrcRecords::Parser::BuildDepRec,
std::allocator<pkgSrcRecords::Parser::BuildDepRec> >::_M_insert_aux ()
#8  0x08058921 in __gxx_personality_v0 ()
#9  0x00c2f2db in CommandLine::DispatchArg () from
/usr/lib/libapt-pkg-libc6.4-6.so.2
#10 0x0805d4d7 in __gxx_personality_v0 ()
#11 0x0091af2c in __libc_start_main () from /lib/libc.so.6
#12 0x0804cb91 in __gxx_personality_v0 ()
==============================================

[root@localhost]# apt-get --version
apt 0.5.15lorg3.2 for linux i386 compiled on Sep 16 2006 07:45:26
Supported Modules:
*Ver: Standard .rpm
*Pkg:  rpm interface (Priority 20)
 S.L: 'rpm' Standard RPM binary tree
 S.L: 'rpm-src' Standard RPM source tree
 S.L: 'rpm-dir' Local RPM directory tree
 S.L: 'rpm-src-dir' Local SRPM directory tree
 S.L: 'repomd' RepoMD tree
 S.L: 'repomd-src' RepoMD src tree
 Idx: RPM Source Index
 Idx: RPM Package Index
 Idx: RPM Database
Comment 4 Panu Matilainen 2006-12-11 15:13:58 EST
Yup, it's a dupe of #211254.
Comment 5 Axel Thimm 2006-12-11 15:50:31 EST

*** This bug has been marked as a duplicate of 211254 ***

Note You need to log in before you can comment on or make changes to this bug.