Bug 219140 - Problem with g_spawn_async_with_pipes or GTK Tree View
Problem with g_spawn_async_with_pipes or GTK Tree View
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: glib2 (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-11 09:31 EST by Bob Doan
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-05 09:37:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Valgrind Trace (33.86 KB, application/octet-stream)
2006-12-11 09:31 EST, Bob Doan
no flags Details

  None (edit)
Description Bob Doan 2006-12-11 09:31:22 EST
Description of problem:

I believe their is either a problem w/ g_spawn_async_with_pipes or a deeper
problem.  I noticed the problem w/ using the geany geany.uvena.de text editor. 
It has a feature to run "make" and show the output in a window.  If I run make
(on a large compile) and I open the Open File dialog (more then once), the
program will crash.  I was able to trace it down to geany's src/build/.c line 442.

I have a valgrind trace so you don't think I'm crazy.


Version-Release number of selected component (if applicable):
gtk2-2.10.4-6.fc6
glib2-2.12.3-2.fc6
Comment 1 Bob Doan 2006-12-11 09:31:22 EST
Created attachment 143294 [details]
Valgrind Trace
Comment 2 Bob Doan 2007-01-05 09:37:25 EST
It looks like this was really a gtk bug and it is fixed in the latest gtk svn


Note You need to log in before you can comment on or make changes to this bug.